Do i need to return my touch?

Discussion in 'iPod touch' started by ds252, Sep 25, 2007.

  1. ds252 macrumors regular

    Joined:
    Aug 6, 2007
    #1
    When i first got my touch i put a video on and it worked perfectly, now all videos i put on show purple and blue bloges everywhere, do i need to return it or is it just the videos?

    even videos off of youtube don't work now, week 38 too now i have to return it
     
  2. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #2
    i visited an apple store that had a touch with a similar problem. i was really shocked to see that. i tried turning it off and on, and it seemed to fix it. have you tried that? maybe a hard reset (press and hold home and sleep/wake buttons)? if it doesn't take care of the issue, then you should go to an apple store to have yours exchanged.
     
  3. ds252 thread starter macrumors regular

    Joined:
    Aug 6, 2007
    #3
    That fixed it for the time being could it be that it's been on for the past 5 hours straight or is this going to continue do you think?
     
  4. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #4
    give it some time. if the problem persists to an annoying level, then i'd take it apple. be sure you can replicate the problem in front of the genius, however, because showing a problem is much more convincing than describing a problem. good luck with your touch, and let's hope the problem doesn't come back.
     
  5. BII macrumors member

    Joined:
    Sep 1, 2006
    #5
    I had that problem, and it turned out that my touch still had 1.0 version software on it. upgraded, and the problem went away.
     

Share This Page