Do I need to upgrade to 3.1.2 before JB 4.0?

Discussion in 'Jailbreaks and iOS Hacks' started by theman510, Jul 5, 2010.

  1. theman510 macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #1
    Currently have a jailbroken 3GS on firmware 3.0 using redsn0w last year. I haven't done anything in terms of upgrading because I really didn't see a need to lose the jailbreak and have to do everything all over again. I used f0recast and I have the old baseband and it's saying I am good to jailbreak and unlock.

    Now, I sold the phone on ebay to pay for my iphone 4. I want to have it jailbroken and unlocked on 4.0 for the buyer. According to the modmyi walkthrough ( http://modmyi.com/guides/how-jailbreak-iphone-3gs-4-0-pwnagetool-os-x/#more-3270 ) it says I NEED to be on 3.1.2 and jailbroken. Does this mean I have to jailbreak to 3.1.2 and then do it all over again for 4.0? Is there any way to go straight from 3.0 to 4.0? Sorry if this is a dumb question but I want to make sure I don't screw this up and not be able to send it jailbroken and unlocked to the buyer. Is there a guide going from 3.0 to 4.0?
     
  2. dvdhsu macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA
    #2
    Get the blobs all backed up, and create an IPSW with PwnageTool.

    You should be fine that way.
     
  3. theman510 thread starter macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #3
    Ok so I don't have to go to 3.1.2 and then do it again for 4.0. Thanks!
     
  4. dvdhsu macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA

Share This Page