Do I really have to update my OS software to use my new iPod?

Discussion in 'iPod' started by johnathan1, Dec 21, 2008.

  1. johnathan1 macrumors newbie

    Joined:
    Oct 25, 2006
    #1
    I just bought an iPod touch, and my computer is a 12" PowerBook G4 with OSX 10.3.9...and iTunes will not recognize the iPod, and I can't install the latest version of iTunes, because it says it needs at least system 10.4.9.

    So does this mean I have to actually buy the system software in order to even use my iPod?? :mad:
     
  2. aethelbert macrumors 601

    Joined:
    Jun 1, 2007
    Location:
    Chicago, IL, USA
    #2
    Yes it does. None of the last two rounds of iPods have been been able to run on Panther.
     
  3. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #3
    Well this sucks for you.
    You should have thought this through before buying your iPod.
     
  4. johnathan1 thread starter macrumors newbie

    Joined:
    Oct 25, 2006
    #4
    Will my computer even run the newer system software?
     
  5. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #5
    Easily, provided you can find a copy of Tiger these days.
     
  6. johnathan1 thread starter macrumors newbie

    Joined:
    Oct 25, 2006
    #6
    What version is Tiger? (Please excuse my n00bishness) lol
     
  7. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #7
    You can probably find any version of Tiger on eBay.
    About the version; most likely the latest one.
     
  8. ZiggyPastorius macrumors 68040

    ZiggyPastorius

    Joined:
    Sep 16, 2007
    Location:
    Berklee College of Music
    #8
    As bluntly rude as this post is, it's kind of right. The iPod boxes say on them that they will not work on any Mac OS X version before Tiger (I think 10.4.11).
     
  9. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #9
    I suppose it was rude.
    I was trying to get across the point you stated.
     
  10. donga macrumors 6502a

    donga

    Joined:
    May 16, 2005
    Location:
    AZ
    #10
    tiger is 10.4, the newest is leopard 10.5

    i still run 10.3.9 on my powerbook and it's fine, i just know that if my 5.5G ipod ever craps out i'll need to upgrade for the new ones.
     
  11. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #11
    Not too unusual, expect all the next Apple Application updates to require OS X 10.6 right after the OS update.

    At that point 10.4 will the EOL'd, and 10.5 will just sit with minor bug fixes after one or two big updates, and then security updates until EOL'd.
     

Share This Page