Do I really need iOS 6 to link my iPhone 5 to iTunes?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ecorrea85, Nov 23, 2012.

  1. ecorrea85 macrumors newbie

    Joined:
    Nov 23, 2012
    #1
    Just got my new iphone5, so I'm pretty excited to load my music onto it. However when I try and install the required Itunes 7, I get this message: "This software requires Mac OS X version 10.6.8 or later."

    My macbook is pretty old, probably 6 or so years, however just because I have an older version, does that really mean I can't use my new iphone to its full potential? Do I really have to purchase an OSX 6 software package?

    Your help would be much appreciated.

    Thanks.
     
  2. McGiord, Nov 23, 2012
    Last edited: Nov 23, 2012

    McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #2
    It's not mandatory, and starting with iOS 6 you can have your iDevices independent of a computer. You can sync over the air with your iCloud account.
    And yes some things require newer Mac OSX, Safari and iTunes.
     
  3. ecorrea85 thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #3
    seems to be mandatory since i cant get my itunes 7 downloaded (required to sync my music to my iphone 5) without first having the mac osx 10.6.8 (which seems to cost me money).
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Yes.
    Pretty much apple wants you to kick in some money and upgrade.
    Doesn't make sense why iTunes and the iPhone can't sync with your old mac where it syncs fine with ancient windows machines running windows xp still.
     

Share This Page