Do Not Disturb - Blocked Calls?

Discussion in 'iOS 6' started by Nonono, Jun 25, 2012.

  1. Nonono macrumors newbie

    Joined:
    Mar 18, 2012
    #1
    Tried out a little test today with Do Not Disturb. While it was enabled with only allowing favorites to come through I *67 my number to see if the phone would send it to voicemail. It didn't! The call came through.

    Just wondering if you guys can give this a try and see what results you get. Hopefully this will be fixed.
     
  2. Xenc macrumors 6502a

    Xenc

    Joined:
    May 8, 2010
    Location:
    London, England
  3. Nonono thread starter macrumors newbie

    Joined:
    Mar 18, 2012
    #3
    I was meaning for people to try this with their own phones.
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    I read that here before, not sure of the thread, but blocked calls do come through.
     
  5. *Calypso* macrumors regular

    Joined:
    Dec 16, 2011
    Location:
    Germany
    #5
    Had the same issue. To me DND mode makes no sense if blocked calls still come through. I hope Apple fixes this in the final release.
     
  6. Futhark macrumors 65816

    Futhark

    Joined:
    Jun 12, 2011
    Location:
    Northern Ireland
    #6
    That's a bad mistake. That's the type of number I definitely don't want disturbed by. I don't answer withheld numbers at the best of times.
     
  7. Ste Nova macrumors 6502

    Joined:
    Jan 20, 2012
    Location:
    LL22, UK
    #7
    i'd be happy if i could just set blocked calls to make no noise! on my classic nokia the default ring tone is non and everyone is allocated a ring tone = blocked dont even ring :)
     
  8. Mad Mac Maniac macrumors 601

    Mad Mac Maniac

    Joined:
    Oct 4, 2007
    Location:
    A little bit of here and a little bit of there.
    #8
    While this is an error that needs to be fixed, I think I have received a blocked call maybe 4 times in my entire 4 years of owning an iPhone. And zero on my cell phones before that. So I'm not particularly worried...
     
  9. daviddth macrumors 6502a

    daviddth

    Joined:
    Jun 29, 2009
    Location:
    Australia
    #9
    I get them all the time here and it annoys me. Honestly 2-3 a week would not be that uncommon, plus a few people I know have blocked or private numbers and they always manage to call me when I'm in bed after nightshift lol
     
  10. frunkis54 macrumors 65816

    frunkis54

    Joined:
    Apr 2, 2009
    #10
    yes this is a issue since ios6 came out. I noticed it the second or third day and sent in a bug report so they are aware of it.
     
  11. grantsdale macrumors 6502a

    Joined:
    May 11, 2008
    #11
    By 'come through' do you mean the phone actually rings? If so, that's bizarre.

    Or are you under the impression that DND means your phone is effectively turned off and calls are denied/blocked?

    if its the second one, DND doesn't do what you think it does. All it does it not alert you when calls/messages come in.
     
  12. Nonono thread starter macrumors newbie

    Joined:
    Mar 18, 2012
    #12
    Yes the phone rings. Feel free to try it for yourself.
     
  13. kevo1011 macrumors regular

    Joined:
    Oct 3, 2010
    #13
    Can you set days with different times or is it just times? It would be nice to have the ability to set specific days with times.
     
  14. *Calypso* macrumors regular

    Joined:
    Dec 16, 2011
    Location:
    Germany
    #14
    No, just times at the moment. I would prefer a more advanced setting too. It's kind of annoying if your phone goes dead silent at 10 pm on a weekend while you're out partying. :D

    But I am almost certain that Apple will include this + geofencing in the final release. Otherwise it would just be too inconsistent compared to the alarm clock and reminders.
     
  15. DrSD macrumors member

    Joined:
    Sep 18, 2008
    Location:
    Melbourne
    #15
    Nope it does not ring. After putting your phone in DND mode press the sleep awake button and then try it says the ph you calling is busy!
     
  16. 0penCr8 macrumors newbie

    Joined:
    Jul 8, 2012
    Location:
    California, USA
    #16
    Agreed.
     

Share This Page