Do not disturb doesen't silence my calls

Discussion in 'iOS 6' started by FatPuppy, Jan 14, 2013.

  1. FatPuppy macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #1
    The title says all,I restored my iphone as new iphone and it doesen't work anymore.
     
  2. nepalisherpa macrumors 68020

    nepalisherpa

    Joined:
    Aug 15, 2011
    Location:
    USA
    #2
    Make sure that people who are calling you are not on your "favorite" list or make sure the option "Allow Calls From" is set to "No One". Another thing is, DND only works when your phone is locked. If you are playing with your phone, all notifications come through.
     
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
    Are the calls coming from anyone listed as a favorite? ^ edit ... what that dude said.
     
  4. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #4
    Thank you,I didn't know that my phone has to be locked,to bad I can't use my phone during class :))
     
  5. HeezyBear macrumors regular

    Joined:
    May 21, 2010
    #5
    You could just put your phone on silent and turn Vibrate on Silent off in the Sounds setting.
     
  6. Oui macrumors 6502

    Joined:
    Nov 9, 2012
    #6
    DND need some tweaking. It should be just that. Regardless of whether iPhone is locked or not.
     
  7. nepalisherpa macrumors 68020

    nepalisherpa

    Joined:
    Aug 15, 2011
    Location:
    USA
    #7
    Yep! And provide more customizations such as allow text message notifications from favorites as well.
     
  8. thegreatdivorce macrumors regular

    Joined:
    Sep 23, 2010
    Location:
    Upper Left USA
    #8
    Deeper options would be nice. Mine silences calls from non-favorites just fine (except for the first week of January when it tweaked out.)
     

Share This Page