Do Not Disturb isn't working.

Discussion in 'iOS 6' started by WB2Colorado, Sep 20, 2012.

  1. WB2Colorado macrumors regular

    WB2Colorado

    Joined:
    Aug 1, 2008
    Location:
    Durango, Colorado
    #1
    I'm still getting notifications from all my apps.
     
  2. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #2
    It doesn't block my apps like words with friends....just native stuff....its a dumb feature that I've already disabled...
     
  3. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #3
    Only works if your screen is asleep (aka not actively using your phone). And then, you will still get notifications when you wake your screen, but while locked your phone will not light up or play sounds.
     
  4. chisasba macrumors member

    Joined:
    Mar 2, 2012
    #4
    You're supposed to still get them, they just don't make noise or light up when the phone is locked. As far as I know at least.
     
  5. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #5
    Must be a defect with your phone. Been using it for months since the betas came out and it's worked perfectly even with all third party apps.
     
  6. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #6
    you are doing it wrong.



    you are meant to receive notifications from your apps its just that it doesn't wake up your phone nor play sounds.
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    Wouldn't be surprised. I have tons of bugs with this phone.....
     
  8. andybrown44 macrumors regular

    Joined:
    Mar 11, 2011
    Location:
    Hull, UK
    #8
    It only comes into effect when your phone is locked. The notifications will still appear then, but won't wake the screen or make any noise/vibration.

    If your phone is unlocked, notifications and calls will come through as normal.
     
  9. jsg7 macrumors newbie

    Joined:
    Sep 20, 2012
    #9
    Words With Friends notified me of moves audibly this morning while DnD was still active...

    Phone calls were still silenced, however, so it was on.

    Maybe 3rd party notifications don't work correctly with DnD, but I'd assume DnD should override all the audio notifications. Apple needs to fix it...
     
  10. andybrown44 macrumors regular

    Joined:
    Mar 11, 2011
    Location:
    Hull, UK
    #10
    Was your screen locked at the time?
     
  11. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #11
    I had the same thing happen. Everything else was silent and it worked fine, but wwf woke me up out of a half sleep....
     
  12. jsg7 macrumors newbie

    Joined:
    Sep 20, 2012
    #12
    Yes.
     
  13. Athelstan895 macrumors newbie

    Joined:
    Sep 28, 2012
    #13
    My eBay app still notifies me. Phone was locked
     
  14. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
    #14
    GV Mobile+ push notifications still get through.
     
  15. Ilikesapple macrumors newbie

    Joined:
    Sep 30, 2012
    #15
    I've had it work, in lock screen, for allowing a phone call from someone on the allowed screen. From the same person, texts do not light up the screen nor vibrate, as they are set to do on the phone. I haven't tried any of the WWF-type apps bc I disabled them already :) (Although the disabling of them didn't work for awhile.) I REALLY want DND to work, esp. when my teen stays the night elsewhere.
     
  16. redman042 macrumors 68030

    redman042

    Joined:
    Jun 13, 2008
    #16
    Well this feature is no good for the main reason I was going to use it...

    When using my iPad as a presentation device, hooked up to a projector, I didn't want personal notifications popping up on the screen. That could be... embarrassing. While airplane mode can be a solution, it does nothing for you if you still need the internet.
     

Share This Page