"Do Not Disturb" not working as intendet

Discussion in 'iPhone Tips, Help and Troubleshooting' started by LeandrodaFL, Sep 28, 2014.

  1. LeandrodaFL macrumors 6502a

    LeandrodaFL

    Joined:
    Apr 6, 2011
    #1
    I have iPhone 5 running iOS 6.

    When I set "Do not disturb" on, I tought it was suposed to stop sound and vibration when someone called me. For some reason, when a friend of mine calls, the phone starts ringing.

    I read somehting about "do not disturb" not blocking favorites and if a person calls 2 times in 3 minutes. Is this true for iOS 6? If yes, how do I disable this? morevoer, this friend of mine is not listed as favorite and I believe the phone is ringing on the first call anyways.

    I had to resort to Arplane mode On now when Im in a meeting or a movie...
     
  2. Ntombi macrumors 68040

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #2
    It is working as intended. Uncheck the "repeated calls" option.
     

    Attached Files:

  3. powerstrokin macrumors 6502a

    powerstrokin

    Joined:
    May 18, 2013
    #3
    You could also just flip the switch and put it on vibrate.
     
  4. LeandrodaFL thread starter macrumors 6502a

    LeandrodaFL

    Joined:
    Apr 6, 2011
    #4
    I dont have such option, Im running iOS 6. This photo is from iOS 7. Is this obligatory in iOS 6?


    The vibration itself makes a big noise and the feeling disctracts me. I want complete peace. How do I change settings for do not disturb in iOS 6?
     
  5. powerstrokin macrumors 6502a

    powerstrokin

    Joined:
    May 18, 2013
    #5
    Put your phone in airplane mode then.
     
  6. LeandrodaFL thread starter macrumors 6502a

    LeandrodaFL

    Joined:
    Apr 6, 2011
    #6
    I just found out how to properlly set Do Not Disturb, you have to go into "Notifications" and then you have some extra options. Problem solved, thanks everyone.
     
  7. mofunk macrumors 68020

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #7
    I put mine into Do Not Disturb for a time frame. If the person calls the 6th time the phone will ring overriding the settings.


    Check your settings. It might be best to set a time frame.
     

Share This Page