Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Damolee

macrumors 6502
Original poster
Nov 20, 2012
493
71
Hi folks,

I know there is a known reported bug with the Do Not Disturb feature but does that include scheduling? Usually I have it set to 9pm to 5am, but it seems to have stopped turning on by itself.

In settings it's still enabled and set, tried disabling it completely and setting again to no avail.

Any ideas?
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
51,388
19,449
The bug seems to be specifically with the scheduling part of DND. In particular it mentions that DND doesn't turn off as scheduled...however it wouldn't be much of a stretch to say that it probably doesn't turn on as scheduled either (at this time), although it's hard to say why that's not called out as well.

Having been observing the DND issue on two iPhones (a 5 and a 4), both running iOS 6, I can say that as of the beginning of this year the scheduling part of DND isn't working at all really--it doesn't turn on or off as scheduled.
 
Comment

GoCubsGo

macrumors Nehalem
Feb 19, 2005
35,741
149
As far as I can tell the DND bug affects turning on and off of the feature. I gave up on it. ;)
 
Comment

AlphaVictor87

macrumors 6502a
Sep 7, 2011
797
27
Saint Louis, MO
what the above two said. I found this out last night when i was ALMOST asleep and thought DND had turned on (knew it doesn't turn off) and i got a loud email notification
 
Comment

batting1000

macrumors 604
Sep 4, 2011
7,379
1,674
Florida
You can still turn it on and off and use it like normal, it's the scheduling side of things that is bugged. Apple says it'll automatically resolve itself after January 7th.
 
Comment

sflomenb

macrumors 6502a
Jul 22, 2011
915
132
http://support.apple.com/kb/TS4510?viewlocale=en_US&locale=en_US

Symptoms
After January 1st, 2013, Do Not Disturb mode stays on past its scheduled end time.

Resolution
Do Not Disturb scheduling feature will resume normal functionality after January 7, 2013. Before this date, you should manually turn the Do Not Disturb feature on or off.

To turn off the scheduling feature, tap Settings > Notifications > Do Not Disturb and switch Scheduled to Off.
 
Comment

batting1000

macrumors 604
Sep 4, 2011
7,379
1,674
Florida
However, for some reason, that doesn't mention anything about DND not turning on when scheduled (just not turning off), which is rather strange given that turning on as scheduled seems to be affected as well.

It clearly states the feature will resume normal functionality after the 7th. If it still doesn't turn ON as scheduled after that date, then you can worry.
 
Comment

C DM

macrumors Sandy Bridge
Oct 17, 2011
51,388
19,449
It clearly states the feature will resume normal functionality after the 7th. If it still doesn't turn ON as scheduled after that date, then you can worry.
Sure. Yet, if the issue is with the feature turning on or off based on a schedule currently (as it seems to be), why not mention the "on" part--or simply the scheduling functionality itself--and only reference the "off" part? Simply curious.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.