"Do Not Disturb While Driving" annoys the hell out of me

Discussion in 'iOS 12' started by alexe, Oct 29, 2018.

  1. alexe macrumors member

    Joined:
    Nov 5, 2014
    #1
    I have the activation of "Do Not Disturb While Driving" set to "Manually", because I don't drive very often and therefore have no use for this feature.

    Every time I'm on the subway though, I constantly get a full-screen pop-up asking me to set up "Do Not Disturb While Driving". This pop-up gives you only two options: To either turn on the feature, or to set it up later. However, it provides no "Don't bother me with this ever again" option, so every time I'm on a subway train, iOS is bothering me again and again to activate DND.

    This **** is annoying the hell out of me. Am I the only one?

    Why hasn't there been a huge outcry yet? Everybody using trains, subway, or even the passenger seat must have the same problem.
     
  2. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #2
    Sounds like something isn't happening correctly on your device. If it's set to "Manually" it's not supposed to prompt you (whether you are actually driving or are on a train or really under any condition basically). Perhaps try setting it to a different option and then go back and set it to "Manually" again (and maybe restart your phone). Or perhaps you might even need to reset all of your settings if something else weird is going on for some reason.
     
  3. BugeyeSTI macrumors 68030

    BugeyeSTI

    Joined:
    Aug 19, 2017
    Location:
    Arizona
    #3
    My phone has never asked me to set it up, something is screwy with your phone. I would recommend resetting all settings or you may have restore using iTunes and setup as new to see if the issue goes away. Then restore from a backup to see if it returns. Hopefully your backup doesn’t have the issue..
     
  4. KGB7 Suspended

    KGB7

    Joined:
    Jun 15, 2017
    Location:
    Rockville, MD
    #4
    No issues here and I drive all the time. I have it disabled and set to manual.
     
  5. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #5
    So just turn it on--it won't bother you since you "don't drive very often."
     
  6. Starship67 Suspended

    Starship67

    Joined:
    Oct 28, 2017
    Location:
    LA
    #6
    I've set to manual and never get a pop up and I drive a lot.
     
  7. Nigel Goodman macrumors member

    Nigel Goodman

    Joined:
    Jun 29, 2017
    Location:
    UK
    #7
    Except that it will turn itself on when you are on a bus or train without you realising it. Which is probably not what is required.
     
  8. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #8
    Having it set to "Manually" is the way to go there, it just seems to not be working correctly for some reason in OP's case.
     
  9. sdwaltz macrumors 6502a

    Joined:
    Apr 29, 2015
    Location:
    Indiana
    #9
    How about you just...turn it off, and then don’t look at your phone during the rare times you drive?
     
  10. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #10
    Turn what off?
     
  11. Ntombi macrumors 68040

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #11
    Yeah, something is wrong with your settings.

    I’d turn it on, reboot the phone, and then set it back to manual, and see if that helps. If not, I’d call Apple.

    Mine was set to manual day I received the phone, and it hasn’t bothered me since.
     
  12. TheSkywalker77 macrumors 6502a

    TheSkywalker77

    Joined:
    Sep 9, 2017
    Location:
    Florida
    #12
    If you don’t drive often just turn it off all together. The few times you do drive it won’t be that hard to turn it on manually from the Control Centre.
     
  13. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #13
    Seems like that's what was already happening here (by having it set to "Manually"), it's just that it hasn't been working properly for OP for some reason.
     
  14. TheSkywalker77 macrumors 6502a

    TheSkywalker77

    Joined:
    Sep 9, 2017
    Location:
    Florida
    #14
    I'm saying try disabling DNDWD all together and just use the regular DND and see how it works.
     
  15. Ntombi macrumors 68040

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #15
    You cannot disable it completely. The choices are here. Activating it manually is the closest, which is why we’re telling him something is wrong.
     

    Attached Files:

  16. TheSkywalker77 macrumors 6502a

    TheSkywalker77

    Joined:
    Sep 9, 2017
    Location:
    Florida
    #16
    Oh, I forgot that option was a thing.
     
  17. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #17
    Setting it to "Manually" is basically as close as you can get it "disabling" it.
     

Share This Page

16 October 29, 2018