Do not have sufficient privileges

Discussion in 'macOS' started by themachatter, Jan 5, 2008.

  1. themachatter macrumors newbie

    Joined:
    Nov 11, 2007
    #1
    For some reason my mac won't let me rename any of my files. It comes up with 'You do not have sufficient privileges to rename the item' every time I try. What's the deal?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    What sort of Mac do you have, what OS are you running and what files are you renaming? :)
     
  3. themachatter thread starter macrumors newbie

    Joined:
    Nov 11, 2007
    #3
    SR Macbook on Leopard. I'm trying to rename a video file to .avi on my external hard drive.

    edit: also on a different note, It asks me for my administrator password whenever I try and move a file to my external, is there a way to turn that off?
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Can you rename files on your internal drive normally?
     
  5. themachatter thread starter macrumors newbie

    Joined:
    Nov 11, 2007
    #5
    Yes I seem to be able to do that still. The external is also my time machine drive, if that makes any difference.
     
  6. DukeofAnkh macrumors regular

    Joined:
    Oct 5, 2007
    Location:
    Melbourne
    #6
    Try right clicking on the offending folder/file and choose Get Info. Click the little lock on the bottom right hand corner and authenticate (you have to be an admin to do this). Then, if you're username is in the box at the bottom, change it to Read & Write access, if not, then click the +, add it, and make it Read & Write. If it's a folder, then click the little gear icon down the bottom and select Apply to Enclosed Items.

    That should work but will be a pain if you have several random files/folders doing this. My Time Machine drive went all wacky and it took forever to get all the permissions back so I could access old backups.
     
  7. LtRammstein macrumors 6502a

    LtRammstein

    Joined:
    Jun 20, 2006
    Location:
    Denver, CO
    #7
    It would be a good idea to check to see what access you have. It looks like you have just a regular Standard user access. If that's the case, you'll need to use the Leopard Installation Disk to check it so you are the Administrator.
     
  8. beiju macrumors newbie

    Joined:
    Apr 12, 2008
    #8
    I have this problem too, and in the Get Info window it says I have read & write access. I've tried changing everything to read/write access, and applying it to the folder contents, but no luck. Anyone have any suggestions? I created these files on a different account, which has now been deleted, if that gives you any more insight. And my account is an admin account, although not the primary one (created when I first got the computer).
     
  9. driller2262 macrumors newbie

    Joined:
    Sep 1, 2008
    #9
    Same problem after copying audio / video_TS files. Irritating but work round involves copying then renaming duplicate.
     
  10. RonThom macrumors newbie

    Joined:
    Jan 14, 2009
    #10
    Privilages

    Having the same problem changing file titles in Leopard on an external drive. Following the recommendation above from DukeofAnkh on Oct 2007 and going through the "Get Info" steps recommended worked to fix the whole dirve by doing Get Info for the drive itself and not just individual files.
     
  11. pythagorean macrumors newbie

    Joined:
    Feb 23, 2009
    #11
    Privileges can be confusing.

    RonThom brings up a good point that your external also has its own permissions. For a couple of the people on this thread, it sounds like it may be the case that they are using an external drive that was created by a different computer or a different user on their computer. Just try to think the whole process through on both ends: the permissions of the files on your local cpu and the permissions of your external or network drive.

    Also, if you are connecting to a network storage device, you may be logged in to the network drive as a different user than the user that you are on your local computer, so you may have to add that user to the files permissions in order to be allowed to do everything you want to do.

    Permissions can sometimes seem like a pain, but the way that macs and linux handle them is really logical and many neat things that help everything just work are using them all the time.
     
  12. MAYBL8R macrumors member

    Joined:
    Jun 5, 2007
    #12
  13. xanish macrumors newbie

    Joined:
    Sep 16, 2009
    #13
    I have a similar problem

    Hi,

    So, I'm having a similar problem...

    Except it's on my external hardrive. I lent my brother my external hardrive (which I have done before) and when he gave it back, it had some random files on it. At first I didn't give it much thought, because since he uses windows it does that sometimes. But I've always been able to just delete the files.

    But this time there is a folder that simply will not delete, and I haven't been able to do anything to change it. I deleted the files inside the folder successfully.

    I tried renaming the file and it said that I did not have sufficient privileges. But I'm the only person that uses my computer, there are no other accounts...

    I downloaded Batchmod, but no matter what I did, it made no difference to how the folder responded.

    Any ideas?


    P.S. In case it helps, the folder is called RECYCLER. I thought it could be virus for a while, but I ran a scan on iAntiVirus and nothing was detected.
     
  14. pavinder macrumors member

    Joined:
    Jan 16, 2009
    #14
    I found an identical problem today.

    This folder called "RECYCLER" (in upper case) which contains another folder with a long string of numbers (but zero size) is undeleteable despite showing read and write access.

    Research shows it's a Conficker worm from Windows.

    This worked to delete it, but requires a windows machine:

    Got to a DOS prompt using Start > Run
    at the prompt typed CMD and hit the OK button

    C:> e: (enter)
    E:> cd recycler (enter)
    E:\RECYCLER>attrib /d /s (enter)

    this showed me SHR xxx (xxx=the foldername-long string of numbers)

    E:\RECYCLER> attrib -r -s -h xxx (enter)
    E:\RECYCLER> rmdir xxx
    E:\RECYCLER> cd .. (enter)
    E:> attrib /d /s (enter)

    this showed me (among other lines) SHR RECYCLER

    E:> attrib -r -s -h recycler (enter)
    E:> rmdir recycler (enter)

    Done
     

Share This Page