Do you have unreliable Email?

Discussion in 'iPhone' started by Xtoo, Jul 9, 2007.

  1. Xtoo macrumors member

    Joined:
    Jun 29, 2007
    Location:
    Valencia, CA
    #1
    Mail has been unreliable the last few days. iPhone is able to download email (Gmail, .Mac and POP), but I have not been able to succesfully send email everytime.

    I have tried both EDGE and Wi-Fi at different times and different places (home, supermarket, office, coffeee shops, the streets-EDGE) both ways don't work all the time and the composed message goes to the outbox for a long time.

    Right now, I tried to send a short text email through .mac account via iPhone without success (4PM Pacific). I sent the email through my mac (.mac online), and was automatically shown on iPhone in the sent folder. So download is fine but send is not.

    Do you guys have the same issues? Is this normal smart phone behavior?
     
  2. CyberGreg macrumors regular

    Joined:
    Jan 2, 2004
    Location:
    SoCal
    #2
    Just used EDGE with my .mac account, read and sent messages.
     
  3. tttexxan macrumors 6502a

    Joined:
    Jun 25, 2007
    #3
    might do a power down on your phone and the try right afterwards to see...Sometimes programs or feature get locked up
     
  4. DiamondMac macrumors 68040

    DiamondMac

    Joined:
    Aug 11, 2006
    Location:
    Washington, D.C.
    #4
    Mail has been pretty consistent to be honest.

    What has NOT been reliable is voicemail. I get voicemails not 1 day later but even 2 days later :mad:
     
  5. applehappy macrumors regular

    Joined:
    Jun 22, 2007
    #5
    Same email problems here. I'll send an email or two then learn they didn't get sent. For yahoo mail I've learned to check the sent mail folder and if my mail doesn't appear there then it didn't get sent. I've found resyncing the iphone seems to clear up the problem. Very sporadic and irritating email problem.
     
  6. Xtoo thread starter macrumors member

    Joined:
    Jun 29, 2007
    Location:
    Valencia, CA
    #6
    I found out yesterday that there was a glitch on the software and was advised by Apple tech support to "restore" iPhone's software. So I came home and did it. By the way, it is an interesting process; but anyway, the restore did not fix the issue. I did not want to call tech support again, I had to wait about 30 min. total just to get through the first time (about 8PM Pacific).

    I decided to take measures on my own. I deleted all the mail accounts (3 - .Mac, Gmail & POP) to then re-create them manually. After I deleted them, I turned the phone off for a few minutes before input all the mail accounts info. It probably took about 10 - 15 minutes to do it all and presto! it worked like a charm.

    Then I spent another 10 -15 min, sending and receiving test email from all accounts through both Wi-Fi and EDGE networks. So far everything works, I didn't not lose any of my info on the phone, neither I got 100+ emails like the first time I set up iPhone a week ago (nice!). iTunes keeps somewhere a "back up file" of all synced stuff that quickly puts the iPhone back to how it was (again nice!).

    Hope this helps some people....
     
  7. transamman1999 macrumors member

    Joined:
    Jun 27, 2007
    #7
    my mail has been very moody as well. sometimes it works perfect, other times it wont work at all. very annoying.
     
  8. DiamondMac macrumors 68040

    DiamondMac

    Joined:
    Aug 11, 2006
    Location:
    Washington, D.C.
    #8
    Mail has actually been VERY reliable for me on the iPhone. very impressed with it.
     

Share This Page