Do you need iTunes 10.5 to install iOS 5 beta 4?

Discussion in 'iPhone' started by Imola Ghost, Jul 24, 2011.

  1. Imola Ghost macrumors 65816

    Joined:
    Mar 21, 2009
  2. Saberon macrumors 6502a

    Joined:
    Sep 16, 2008
  3. mattdo93 macrumors 6502

    mattdo93

    Joined:
    Oct 2, 2010
    #3
    You need iTunes 10.5 beta 4 to sync a device that's running iOS 5 beta 4 and for wireless sync to work properly (if you're running Windows)
     
  4. wvphysics macrumors regular

    Joined:
    Jul 7, 2010
    #4
    I am guessing by your question you are new iOS beta. Beware that there are plently of bugs. For instance, beta 4 will empty your photo albums. Be sure to backup your phone first and read the patch notes. Also, I'd recommend making a copy of the backup in case something screws up and the backup gets overwritten. If any of the makes you nervous, you should wait.
     
  5. Nicolas4ever macrumors 6502a

    Nicolas4ever

    Joined:
    Jul 7, 2010
    #5
    you'll be able to upgrade from beta 3 to beta 4 via OTA but when you'll need to sync it you must have the itunes 10.5 beta 4
     

Share This Page