Doc "stuck" in TextEdit

Discussion in 'OS X Mountain Lion (10.8)' started by rbtroj, May 21, 2013.

  1. rbtroj macrumors newbie

    Apr 2, 2013
    I had a file open in TextEdit, saved it, and later put the machine to sleep with the document still open. The next day, after waking the machine I went to quit TextEdit and received a message asking if I wanted to save or revert changes before quitting. Since I hadn't made any (intentional) changes I tried to revert changes but get the message "This operation couldn't be completed. (GSLibraryErrorDomain error 2.)" I didn't want to save the file because I was afraid that any inadvertent changes might have an adverse effect. I force quit TextEdit thinking that would just leave the file unchanged on the drive (or corrupt it horribly). However, whenever I restart TextEdit that same doc always reopens automatically and I cannot figure out how to get out of this loop. I've checked permissions on the file and even rebuilt disk perms, but still no luck. Any help is appreciated.
  2. benwiggy macrumors 68020

    Jun 15, 2012
    Normal behaviour is for an app to reopen the documents open when it quit, of course. You can turn this off in System Preferences. It's also possible to launch the app with a meta-key held down to force no docs -- I can't remember which one -- try Command, alt, and ctrl.

    The error message, a quick Google reveals, is a problem with the Versioning -- the way that versions of the file are auto-saved every 5 mins.

    Repair Permissions does NOTHING for user files. It is NOT your go-to-guy for every problems in OS X. I would however boot to another volume (e.g. Recovery Partition) and Repair the Drive, just in case you have some disk problems.

Share This Page