Dock blocking maximized photoshop

Discussion in 'Mac OS X Lion (10.7)' started by kjid, Dec 21, 2011.

  1. kjid, Dec 21, 2011
    Last edited by a moderator: Dec 21, 2011

    kjid macrumors regular

    May 3, 2011
    In previous osx versions, adobe's photoshop canvas would get 'under' the dock when you press the F key to make it full sized. With lion the dock seems to block it, leaving unused space (see example below). Being on an 11" MBA i'd like photoshop to use up that space.


    Does anyone know a solution for this?

    I've tried searching on this topic, but with no results.
  2. kamuix macrumors regular


    Feb 9, 2011
    Hrm I was experimenting and I was able to drag my work window behind the dock. I don't seem to have the issue where it stops at the dock. I'm running Lion with CS3. A solution I found, if you want to go this route, is to hide the dock. Under system pref/dock, you can check automatically hide and show the Dock. It hides the dock and when you hover over the region where your dock is, it pops back up. I was able to drag my work area over the region where the dock was. Also, it would stay away if you have photoshop selected. I had to click on my desktop and hover over my dock area for it to show.
  3. GGJstudios macrumors Westmere


    May 16, 2008
    Have you tried turning turning hiding on for the Dock?
  4. mainstay macrumors 6502


    Feb 14, 2011
    Another workaround that I use when my VLC suddenly does this same thing in Lion, is to use a shortcut of command-d (i set it in system preferences >> keyboards >> keyboard shortcuts).

    So if VLC / Lion stops behaving at full screen I just hit command-d and all is right in my world.

    I don't know if this is some sort of conflict with Lion's control of fullscreen applications or not, but this is a quick, semi-satisfying work around.
  5. kjid thread starter macrumors regular

    May 3, 2011
    thanks for your replies. I did turn of the dock, and while that does allow photoshop to get into full screen, it's not what i'm used to. I think i've gonna have to get used to that tough :).

    Kamuix; I can drag a window under the dock, but i usually work in 'full screen' mode (shortcut F) and thats when the dock is blocking it.

Share This Page