Dock disappeared - old problem but new situation

Discussion in 'Mac Basics and Help' started by too2simple, Nov 8, 2012.

  1. too2simple macrumors newbie

    Feb 16, 2011
    Hi all, I searched thé forum for earlier dock-disappeared posts and found no similar situations, so I start this new thread to seek help. In short, everything worked well this morning and thé machine shutdown normally. But thé dock disappeared this afternoon when I powered it on.

    In the Console tool - all messages window, I found thé following:

    12-11-08 22:50:30,000 kernel: disk0s2: I/O error.
    12-11-08 22:50:31,396 ([444]) Job appears to have crashed: Bus error: 10
    12-11-08 22:50:31,846 ReportCrash: Saved crash report for Dock[444] version 1.8 (1040.42) to /Users/macbook/Library/Logs/DiagnosticReports/Dock_2012-11-08-225031_maciosdev.crash
    12-11-08 22:50:31,875 ReportCrash: Removing excessive log: file://localhost/Users/macbook/Library/Logs/DiagnosticReports/Dock_2012-11-08-224535_maciosdev.crash

    Then after every (about) 13 seconds, the same set of 4 error messages repeat. I take a look at thé disk0s2 partition, and it is clear to be thé mac os x system partition which starts up as usual. I can still use thé TextEdit, Firefox, etc. to report this problem. However the interaction does slow down quite a lot, which seems to be understandable if the system accesses the said problematic partition every 13 seconds (but for what?). I don't see any suspicious process with "ps -ef" btw.

    maciosdev:Logs macbook$ df -k
    Filesystem 1024-blocks Used Available Capacity Mounted on
    /dev/disk0s2 243498500 85266476 157976024 36% /
    devfs 112 112 0 100% /dev
    map -hosts 0 0 0 100% /net
    map auto_home 0 0 0 100% /home
    /dev/disk0s4 243909628 219671824 24237804 91% /Volumes/Untitled
    maciosdev:Logs macbook$ pwd
    maciosdev:Logs macbook$

    But I still launch thé Disk tool to verify this partition, again thé tools says it's in good state. My system was 10.7.2. After encountering this strange problem, I updated it to 10.7.5 but the upgrading did not solve thé problem.

    I tried also "chkdsk" but -bash says this command is not found.

    Any hints? Thanks a lot. It's driving me crazy!
  2. too2simple thread starter macrumors newbie

    Feb 16, 2011
    I should add that the screen flashes every (about) 13 seconds too! What's the os doing?

    Oh yes, it suddenly does not recognize USB key now. This came with the dock-disappearance problem roughly at the same time (but not 100% sure).

    Everything else (startup, reboot, shutdown, launching applications) seems just fine...
  3. too2simple thread starter macrumors newbie

    Feb 16, 2011
    Amazingly, the dock came back by itself... Frustrating is that I didn't know why it disappeared and I don't know why it is back to normal either... I don't find sufficient log information in the Console tool. What's only obvious is the disappearance of the set of 4 error messages which occurred every 13 seconds.

    It's probably related to utorrent. I vaguely recall that on the day the dock disappeared I changed some utorrent settings. Today, I upgraded utorrent from 1.6.x to the latest 1.7.x and also adjusted some settings. But in both cases, the effect is not immediate. I mean, the dock did not disappear/reappear immediately after a reboot after the change of the utorrent settings.

    Any possible explanations?
  4. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Not sure if you're saying it reappeared after a reboot, but that's what I would have tried first. That it didn't disappear immediately after a reboot is not surprising. The reboot wouldn't cause a problem. The problem appeared on its own schedule, so to speak.
  5. too2simple thread starter macrumors newbie

    Feb 16, 2011
    i meant:

    on the day of the problem: i changed settings of utorrent; reboot, and the problem did not happen immediately; after quite some time, the dock disappeared and error messages began to merge in the Console log.

    on the day of back to normal: i upgraded utorrent and changed some settings again; reboot, the dock did not reappear immediately; after quite some time, the dock came back and error messages stop to append in the Console log.
  6. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    So the reboot is not the trigger in either case. That's odd. I don't know anything about utorrent, but I also don't know what else you're opening. You could trash the Dock's plist file and see if that keeps it behaving normally. (Sorry if you mentioned trying that above.)
  7. too2simple thread starter macrumors newbie

    Feb 16, 2011
    Yes, I had tried that after an Internet search...

Share This Page