Dock Folder problem

Discussion in 'macOS' started by Nuks, Mar 13, 2008.

  1. Nuks macrumors 6502a

    Joined:
    Feb 25, 2006
    #1
    Hey everyone,

    I was tyring to mod my dock, but I couldn't replace a file in Resources, so I dragedd the Resources folder to the desktop (where i had sufficient privileges), did what I needed to with it, and then tried to put it back in its original spot. However, it said I don't have sufficient privileges, and now only three or four of the files have been moved there. The dock is running fine now, but there are loads of files missing from the correct spot.

    So basically, I have a folder on my desktop that I need to move somewhere where I can't move it. I'm the admin on the computer, but my password isn't enough to do the job.

    Any help?
    Thanks.
     
  2. DukeofAnkh macrumors regular

    Joined:
    Oct 5, 2007
    Location:
    Melbourne
    #2
    Moving the entire resources folder to the desktop probably wasn't the best idea. I suspect it would have copied over rather than actually moved it since dragging around files in the resources folder copies them to the new location by default. Anyway, for modding dock files replacing files doesn't work for some reason (forgot why). You need to delete the old file then copy over the new one to replace it. That's always worked for me while replacing didn't.

    If you actually killed files that should be in resources, I recommend trying to get them back with Time Machine or something.
     
  3. Nuks thread starter macrumors 6502a

    Joined:
    Feb 25, 2006
    #3
    Yeah, deleting it first did it!

    Thanks so much!
     

Share This Page