Dock graphic missing when switching profiles

Discussion in 'OS X Mountain Lion (10.8)' started by Sir Ruben, Jan 31, 2013.

  1. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #1
    Strange problem that seems to happen most of the time. I have one main profile (mine) which is booted most of the time. However when my daughter logs in to her profile the shiny glass-like dock graphic is not there. However all the dock icons are still present and functional.

    If I log out of the profile and back in it displays as it should. Does anyone else get this or have a solution. Its an annoying niggle that gets on my nerves lol
     
  2. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #2
    This is basically what Im getting:

    [​IMG]

    also launchpad has a dimmed effect to it:

    [​IMG]
     
  3. g-7 macrumors 6502

    g-7

    Joined:
    Feb 14, 2006
    Location:
    Poland
    #3
    I hate it too. Happens on my iMac when I use fast user switching. Restarting the Dock ("killall Dock" in Terminal) helps.

    Open AppleScript Editor and type in the following script:

    Code:
    do shell script "killall Dock"
    Save it as an application, name it Restart Dock or something. When your Dock loses its background, just double-click Restart Dock icon.

    You may put it in the Dock ;)
     
  4. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #4
    Thanks thats actually very useful. At least I know it happens to others as well. I was beginning to think I was the only person to have ever experienced it. Something I found hard to believe as I have just switched from Windows 7 to Mac OSX Mountain Lion and seen far more bugs than I ever expected from the almighty Mac.

    The other one I particularly hate is when you view the info of a file only to find many of those details gone forevermore the second time you try to view it. Surely simple bugs for Apple to squash!?
     

Share This Page