Dock icons corrupt (I think)

Discussion in 'OS X Mavericks (10.9)' started by nitromac, Nov 14, 2013.

  1. nitromac macrumors 6502

    Joined:
    Jul 29, 2012
    Location:
    US
    #1
    So my MBP went to sleep for a few seconds (inactivity) and I woke it up and logged back in like usual, and found my dock like this:

    [​IMG]

    I restarted the computer and that did nothing. Tried killall -KILL Dock in terminal and that did nothing either.

    The dock itself functions normally but the icons are all messed up as you can see. They're not missing in the app launcher so I have no idea what's causing this.

    What's weird is that some icons are there, some are static, some are totally invisible, and it looks like it has nothing to do with whether or not it's an Apple/system app or third party.

    Anyone else have this happen before?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    This happened because the Dock's icon cache got corrupted somehow. Fortunately, fixing this isn't hard. Hold down Option/Alt and click the Go menu in the Finder. Choose Library. Navigate to Caches. Find the com.apple.Dock folder. Delete it. Restart the Dock using your favorite method.
     
  3. echo1877 macrumors member

    echo1877

    Joined:
    Nov 10, 2015
    #3
    I will resurrect this ancient thread because this is happening to me on El Capitan, and the com.apple.Dock folder doesn't seem to exist here any longer. Has anyone seen this under El Capitan? Screenshot 2016-01-31 16.16.28.png
     
  4. computiNATEor macrumors newbie

    computiNATEor

    Joined:
    Nov 5, 2015
    Location:
    Orange County, CA
    #4
    Sorry to resurrect this ancient thread (again), but I figured out the solution, and thought that it would be helpful to anyone experiencing this issue in the future.

    Yes, I just experienced the exact same issue. I located the Dock's icon cache; it's quite a bit more hidden, but deleting the file and restarting the dock saved the problem.

    1. You need to be able to see all of the files in the Finder. I have an Automator script setup to do that for me, but you can show all the files by following these instructions:

    Show Hidden Files Mac OS X El Capitan:
    1. Click “Finder” icon on your Mac dock.
    2. Open Terminal. Terminal is a utility that provides access to the OS X El Capitan operating system. It can be opened in one of two following ways:
    3. Select “Applications” on the left side, then on “Utilities“, and double-click on “Terminal“
    4. Open the OS X El Capitan Launchpad. Click the “Utilities” folder. Then, double click on “Terminal.”
    5. Enter the following text into the Terminal window, then press “Enter“: “defaults write com.apple.Finder AppleShowAllFiles YES”
    6. Exit the Terminal program. This can be done by selecting “Quit Terminal” from the Terminal menu.
    7. Restart Finder. Your new setting will take effect after you relaunch finder. To do so, hold down the “Alt” key and right-click or two-fingered click on the Finder icon. Select “Relaunch.”
    2. Go to the root level of your boot drive. Look for the folder: "private > var > folders". It will be grayed out, and double-clicking won't automatically open the folder if one is in list view. Use the little triangle.

    3. Inside the "folders" folder (Yes, it's redundant. No, I don't know why), there will be a series of other folders. Inside one of those folders, we are looking for a file whose name matches this exactly: "com.apple.dock.iconcache". There will be other files with "com.apple.dock. ..."; leave those alone.

    4. Once you've located the "com.apple.dock.iconcache" file, move it to the trash and empty the trash. You may be asked for an administrator password.

    5. Relaunch the dock by typing "killall Dock" into Terminal (Applications>Utilities>Terminal). You may be asked for an administrator password.

    6. Hide all of the Finder's files again. Instructions below:

    Hiding Files On Mac OS X El Capitan:
    1. If you want to hide files and not make them visible, you can reverse the process by following these steps.
    2. Select “Finder” icon on the Mac dock.
    3. Open Terminal using one of the two methods described above.
    4. Enter the following text into the Terminal window, then press “Enter“: “defaults write com.apple.Finder AppleShowAllFiles NO”
    5. Exit the Terminal program. This can be done by selecting “Quit Terminal” from the Terminal menu.
    6. Restart Finder. Your new setting will take effect after you relaunch finder. To do so, hold down the “Alt” key and right-click or two-fingered click on the Finder icon. Select “Relaunch.”
    7. Restart your Mac.

    Hope this helps!
     
  5. actionB macrumors newbie

    actionB

    Joined:
    Aug 26, 2016
    #5
    Soooo what fixed this for me was safe mode, and reboot. apparently safe mode repairs cached files and directories too. (shift while booting, maybe check your startup items in case thats part of your problem, then reboot)
    El capitain 10.11.6

     

Share This Page