Dock issues!

Discussion in 'macOS' started by fares.f, Jun 11, 2007.

  1. fares.f macrumors newbie

    Joined:
    Jun 11, 2007
    Location:
    Lebanon
    #1
    Hello,
    I got myself an issue here and i have really tried everything i could think of but no use.
    The issue is the following: my dock was working fine today when all of a sudden after i deleted a couple of files (nothing important, some pics and stuff like that) i go to the trash icon in the dock (usually i click and hold until a small menu pops up and i choose "empty trash") and to my surprise, there is no menu that pops-up.
    I thought at first it was an issue related solely to the trash when i realised that all the icons in the dock stopped showing a pop-up menu to chose to keep in dock when they are active, etc...
    I tried everything, from deleting plists to repairing permissions and disk (which i do on a regular basis by the way). I even created a test account to see if the issue was related to my username or to the system and the problem persisted with the test account...!
    Any advice apart from what i have already tried would be highly appreciated!
    Thx in advance.

    FF
     
  2. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
  3. fares.f thread starter macrumors newbie

    Joined:
    Jun 11, 2007
    Location:
    Lebanon
    #3
    Solved!

    I received the following advice through Apple Discussions and it solved the issue.
    I am mentioning it here so that others would benefit from it as well:

    "Check for this file:
    /System/Library/CoreServices/Dock.app/Contents/Resources/English.lproj/DockMenus.plist
    You are probably missing this file. If you are you will need to restore it from CD or from another Mac.

    If you do have this file, check the modified date and size."
     
  4. myjellyass macrumors regular

    Joined:
    May 1, 2007
    Location:
    Edinburgh, Scotland, UK
    #4
    I know you've resolved this issue, but if it happens to anybody else or if it happens again, i once had a mouse that caused similar problems when it was plugged in. Weird I know, but if you're having problems try unplugging peripherals such as a mouse. (obviously this is only possible on a laptop, so on a desktop try a different mouse.)
     
  5. fares.f thread starter macrumors newbie

    Joined:
    Jun 11, 2007
    Location:
    Lebanon
    #5
    The thing is: i wasn't using a mouse... Thx for the post anyway...
     

Share This Page