Dock items disappear

Discussion in 'macOS' started by si77hay, Oct 5, 2009.

  1. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #1
    Has anybody had any experience with Dock items disappearing? I simply drag and drop the desired application I was to remain in the Dock, and within 10 seconds it just disappears from the Dock!

    I haven't un-installed the application. I did have Dock items selected to Sync in MobileMe, but I disabled that as a test. I've also tried right-clicking the application while it's open, and selecting the 'Keep in Dock' option, but same result. After about 10 seconds of closing the app, it disappears from the Dock.

    I've run Repair Disk Permissions, no effect.

    I found a similar thread on this forum, but it suggested basically wiping the Mac and starting again, which I don't really find as a solution!

    Thanks.

    BTW - Problem on new 15" MBP with 10.6.1
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    I agree, that's too drastic as a first step!

    You could try a fresh com.apple.dock.plist file...

    You'll find that in your Home>Library>Preferences folder.
    Drag it to the desktop.
    For good measure, Restart.
    A new com.apple.dock.plist file will be created in the Preferences folder.
    See if the behavior is gone, if so, you can Trash the file you moved to the Desktop.

    If it's even weirder, you can put that file back where it came from, overwriting the new one.
     
  3. si77hay thread starter macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #3
    Solved

    Thanks for the reply.

    I'm afraid that didn't fully resolve the issue, but it did give me a great starting block!

    I also noticed that not only could make items disappear, but I also couldn't re-arrange dock items. I'd be allowed to drag 'n' drop the item to a new position, but within seconds, it would jump back to where I dragged it from. As if it knew better!

    I resolved by:
    1) Un-registering the iMac and MBP from MobileMe
    2) Deleting the com.apple.dock.plist as you suggested, along with com.apple.dock.db
    3) Re-booting [eek!]
    4) Customising new Dock to original state manually (which I am now allowed to do)
    5) Registered computers with MobileMe, merging all data again apart from Dock, which I replaced on MobileMe

    So...I point my big fat finger at MobileMe as the issue.
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    Glad it works now!

    Thanks for sharing all the steps. That will help others. :)
     
  5. sOwL macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Nerd Cave
    #5
    Mhm... I never used MobileMe so i'm not sure, but from what you said this doesn't sound like a bug... maybe your computer was set to sync your dock with another computer (through mobileme). I'm basing this on your statement saying "merging all data again apart from Dock", so if you actually can merge or sync (or whatever :p) the dock then i bet that was the case here. Anyway, problem solved so i don't think you care that much now heh
     
  6. si77hay thread starter macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #6
    True. I was syncing my iMac with my MBP via MobileMe, but ironically, they were out of sync and I was trying to correct.

    As you said. Problem solved, and my care has diminished! ;-)
     

Share This Page