Dock Problems

Discussion in 'Mac Basics and Help' started by T.Strife, Jan 27, 2008.

  1. T.Strife macrumors newbie

    Joined:
    Jan 26, 2008
    #1
    I have been having problems with the dock failing to auto hide and show. In order for it to appear I have to click the bottom of the screen and once it appears the icons no longer magnify when moused over. File options also fail to highlight when moused over. This has happened before and somehow fixed itself and was fine for a month or so, but now it has resurfaced yet again.

    I have a 2.6ghz MacBook Pro running Leopard. I have tried repairing permissions and relaunching the dock, but nothing has worked.

    Any ideas?


    tia
     
  2. Iscariot macrumors 68030

    Iscariot

    Joined:
    Aug 16, 2007
    Location:
    Toronteazy
    #2
    Are you running any Dock mods? Try picking up a tweaking application and seeing if it's extended Dock options help fix the problem.
     
  3. T.Strife thread starter macrumors newbie

    Joined:
    Jan 26, 2008
    #3

    Nope. No Dock Mods at all. I think the problem must go beyond just the Dock though, since file menus no longer highlight or "spill out" on mouse over. I have to actually click on them.


    I've found one person through Google search with the same problem I'm having (with the only exception being he was running Tiger instead of Leopard)-I believe his question was posted at the Apple Support Forums, but no one could give him a solution. One person suggested going into Library>Preferences>Dock and deleting a certain file (com.apple.dock.plist), but that file isn't present in Leopard.

    I've always auto hid my Dock and this is the first time I've encountered this problem.

    I don't know if this worth mentioning or not, but I'm not actually using my MBP's screen, I have it hooked up to an external monitor. Could this be a possible reason for it? Maybe with the graphics card?
     
  4. T.Strife thread starter macrumors newbie

    Joined:
    Jan 26, 2008
    #4
    Nevermind-I traced the problem to my Logitech mouse. :confused:
     
  5. ioanna macrumors newbie

    Joined:
    Feb 5, 2008
    #5
    hi anyone can help???
    my dock has disappeared completely and don't know how to get it back!!
     
  6. CatieSonnier macrumors newbie

    Joined:
    Sep 9, 2008
    #6
    Same Probelem

    I had the same problem too and couldn't believe how difficult it was to find anyone else who had similar problems!
    I found this site and another where two people had identical problems to mine.
    I read on here that someone traced the problem to their Logitech mouse. I also have a wireless Logitech mouse. I moved the receiver and everything worked like normal!
    Thank you so much!

    Here's the other link that I also found extremely helpful!

    http://www.sorinflorea.eu/2008/03/20/leopard-dock-magnification-freeze/#comment-148
     

Share This Page