Dock using 100% CPU

Discussion in 'MacBook Pro' started by WesCole, Jun 23, 2011.

  1. WesCole, Jun 23, 2011
    Last edited: Jun 23, 2011

    WesCole macrumors 6502a

    Joined:
    Jul 1, 2010
    Location:
    Texas
    #1
    All of a sudden, the dock process on my MacBook Pro is taking up exactly 100% of my CPU constantly. Anyone else have this happen? I heard it may be a problem with the newest build of parallels, but I haven't noticed it until right after I installed today's Snow Leopard update.

    A restart failed to fix the issue, too.

    Thanks for any help.


    Edit:

    After some testing, it is the new build of Parallels (not sure if it is conflicting with the new SL update, though). The only solution I have found is to delete the dock plist and manually change the dock back to my liking. Kind of a pain.

    I hope Parallels gets this fixed quickly, since I need to use Windows on my Mac for school and work.
     
  2. paulionvc macrumors newbie

    paulionvc

    Joined:
    Apr 1, 2011
  3. soulreaver99 macrumors 68020

    soulreaver99

    Joined:
    Aug 15, 2010
    Location:
    Southern California
  4. jogu macrumors newbie

    Joined:
    Jun 24, 2011
    #4
  5. boylerman macrumors member

    Joined:
    Mar 17, 2010
    Location:
    Massachusetts
    #5
    Glad I found this thread! I was pulling my hair out, but your solution worked for me as well.

    I never would have suspected Parallels, since the dock was running at 100% even when Parallels is not running...
     
  6. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #6
    I just started a post on how to undo 10.6.8 as I thought that was it. My MBP always ran cool until yesterday now my fan is screaming at 5000 rpm's and the CPU is staying around 190F, and thats with it sitting there. Anyone else's heat go up by 60deg F?
     
  7. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #7
    I LOVE THIS PLACE!!! I did the fix posted above and my fan is at 1999 and my CPU is back in the 120F range :D

    And I thought it was 10.6.8 that caused it.
     
  8. quepao macrumors newbie

    Joined:
    Feb 11, 2007
    #9
    LOVE YOU GUYS!!!!!!!!!

    i was going crazy also... 99.8% Dock cpu.. constantly..

    3 min google, here i came, fix. jalla =)


    tnx tnx tnx, now its back to speed =)
     
  9. dealmaker macrumors regular

    Joined:
    Sep 24, 2010
    #10
    Thanks guys - just saved me throwing the thing out of the window!

    parallels should have issued a patch or an update/e-mail to all users - bit naughty!
     
  10. jogu macrumors newbie

    Joined:
    Jun 24, 2011
    #11
    Parallels build 12092 is out now, which claims to fix this problem.
     
  11. mellis112 macrumors newbie

    Joined:
    Jul 2, 2011
    #12
    Parallels fixed with latest update

    I was having the same issues today with 99%cpu usage and I did an update with Parallels about an hour ago and it fixed it. Thanks to everyone with their comments and help with this issue. I was ready to take my laptop to Apple.
     
  12. tonyfirshman macrumors newbie

    Joined:
    Nov 30, 2011
    #13
    Dock using 100% cpu

    This happens with Vmware Fusion 4.1.1 as well (very recent upgrade) - well I assume that is the reason my Macbook pro was using over 500% cpu. ..... yes how come with *only* four CPUs (:cool:#

    Incidentally why when posting a reply did I have to type the subject? A bug?

    OS X 10.7.2
    2.3 GHz Intel Core i7
     
  13. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #14
    Where does it show 500% CPU usage? Have you looked at Activity Monitor yet?
    And as you have an i7 in your MBP, you have FOUR cores with TWO threads per core, thus you have EIGHT threads as a whole, which show up as EIGHT cores.


    Do you mean the TITLE field?
    [​IMG]
     
  14. riyo macrumors newbie

    Joined:
    Jul 10, 2010
    #15
    not using parallels

    I see that a lot of you having the issue that DOCK is killing my CPU on my MBAir.

    Most of the solutions are re Parallels ... but I do not have Parallels on my machine.

    Are there any other solutions for getting my CPU back in shape?
     
  15. doktordoris macrumors 6502a

    doktordoris

    Joined:
    Mar 14, 2009
    #16
    I had this issue on my MBA and I just quit the dock process, it then automatically restarted using the normal 0 or 1 percent. I too don't have parallels or any VM software on my Air.
     
  16. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #17
    Amazing. I have an expired trial of Parallels 7 installed on Lion 10.7.3 and have this problem! Thanks for the tip! It still works.
     

Share This Page