Dock will not hide when in full screen mode

Discussion in 'Mac Basics and Help' started by smoke489, Dec 5, 2007.

  1. smoke489 macrumors newbie

    Joined:
    Dec 5, 2007
    #1
    Hello, I have noticed that whenever I enter into full screen more for either joost, quicktime, powerpoint, etc, my dock does not disappear, rather it remains on the screen. I have tried toggling it to hide/unhide and I have also tried restarting the computer altogether, and i have had no luck.

    Any suggestions?

    Thank you:D
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    try re-launching the dock by typing "killall Dock" in the terminal. if this doesnt work try deleting the com.apple.dock.plist preference file in home/library/preferences NB: this will set your dock to default settings.
     
  3. smoke489 thread starter macrumors newbie

    Joined:
    Dec 5, 2007
  4. smoke489 thread starter macrumors newbie

    Joined:
    Dec 5, 2007
    #4
    No, neither seemed to work. The dock still doesn't disappear when entering into fullscreen mode for applications.
     
  5. eric325 macrumors newbie

    Joined:
    Sep 12, 2007
    #5
    Try this: go to system preference, click dock and check automatically hide and show the dock. it work for me.
     
  6. smoke489 thread starter macrumors newbie

    Joined:
    Dec 5, 2007
    #6
    I have tried that before and it didnt work. However, I think I found the solution. There was a system preferences item in the "other" category entitled application enhancer. I believe it came with an app called menufela. Anyway i disabled it and I had no problems with the dock after that. Thank you for your help!
     
  7. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #7
    good to see you solved the problem:). application enhancer is known to cause a few problems with the OS and recently caused the "blue screen" when installing leopard.
     
  8. ecurnes8888 macrumors newbie

    Joined:
    Sep 18, 2012
    #8
    "killall Dock" worked perfect thanks!
     
  9. KingOlim macrumors newbie

    KingOlim

    Joined:
    Sep 21, 2017
    Location:
    Saint Ives, England
    #9

    Can confirm, this worked perfectly for me on macOS Sierra as well!
     
  10. JDHiro macrumors regular

    JDHiro

    Joined:
    Oct 24, 2013
    Location:
    Seattle, WA
    #10
    This is so ()*#$ annoying. "killall -KILL Dock" works fine, but then it just happens again in short order. I have to kill the Dock 2-3 times a day when using full screen apps. Grrrr....
     
  11. desonnaville macrumors newbie

    Joined:
    Mar 21, 2009
    #11
    same issue here.. Already a solution?
     
  12. rjsierra1 macrumors newbie

    Joined:
    Sep 27, 2018
    #12
    Hi, I have the hot corners activated, and it happens to me every time I go to mission control using the top left hot corner, and when I select a full screen app, it show the dock. I test going to this full screen apps using the 4 finger swipe up gesture and it hasn't happened yet. My theory is that this problem has something to do with the hot corners. Any of the others members that have this problem use hot corner to go to mission control?
    --- Post Merged, Sep 27, 2018 ---
    One more thing, Ive tried killall dock and it didn't work for me. Dock keep showing up in full screen apps
    --- Post Merged, Sep 27, 2018 ---
    looks like it has nothing to do... Any other suggestion of what can be done to fix it?
     

Share This Page