Does AirTunes always have at least some glitches?

Discussion in 'Mac Accessories' started by bollweevil, Jan 5, 2010.

  1. bollweevil macrumors 6502

    Feb 1, 2008
    I have tried many permutations: different settings on the AirPort Express, different configurations of Ethernet cables and Wifi, you name it. In every case, there are at least occasional patches of silence lasting 0.5-5 seconds (playback does not pause during this silence).

    My findings:

    If the AirPort Express is not plugged into the Ethernet, but instead forced to use the Wifi coming out of my AirPort Extreme nearby, then the glitches are almost constant. It is so terrible, during five minutes of "playback" there might be thirty seconds of actual sound.

    If the AirPort Express is plugged into the Ethernet, it doesn't matter whether my MacBook Pro is plugged in. There will be occasional glitches. At least some of these glitches are coming from the MacBook-end, because they sometimes coincide with Time Machine backups or processor-intensive tasks.

    What the hell? Is AirTunes just bad? Or is it my MacBook Pro, is it overloaded or does it have some errant process stepping on the AirTunes' toes?
  2. waw74 macrumors 68030

    May 27, 2008
    The only time i have issues with mine is the one in the kitchen that's connected by wi-fi , and that's only when i run the microwave.

    I normally use airfoil to stream, because i will also stream from on my latop to the mini connected to the tv, and an old 1st gen iPhone with a half dead screen sitting in some portable speakers. I'm also going to another airport express that's hardwired to the network and serving my wireless N.
    so 4 speakers, all play fine. and true airtunes also works great.

    does the music continue to play on your laptop if you set it to multiple speakers?

    if you have a 2.4 GHz cordless phone that can interfere with your wifi as well.
  3. bollweevil thread starter macrumors 6502

    Feb 1, 2008
    I would bet a substantial amount of money that, if set to "multiple speakers", my laptop itself will continue playing while the AirTunes is silent. I will do the experiment when I get home.

    Another experiment for me to try:
    Factory-reset the AirPort Express and set it up (for the umpteenth time) and choose "Create a new wireless network". I have done both variants of "Join existing network" i.e. "share internet (WDS)" and "don't share internet, just do AirTunes or Printer share". I haven't tried "Create new network" yet, maybe that will help.

    Yet another experiment:
    Borrow someone else's Mac and see if that streams glitchlessly.

    I doubt the problem is radio interference, because processor-intensive tasks trigger glitches at least some of the time. I could fabricate a situation in which processor burden plus radio interference caused the problem, but I don't think it is likely.
  4. Coroe macrumors member

    Mar 8, 2009
    Sadly, AirTunes is one of Apple's most neglected technologies, although it has great potential.

    Just imagine AirTunes enabled speakers without the need for an AirPort Express. Everything syncs just perfectly fine over 802.11n. Cables are so 1900.
  5. AppleNewton macrumors 68000


    Apr 3, 2007
    1 Finite Place
    I have two AEX for two sets of speakers. exact pair of speakers.
    I get random cut outs where it just stops sending the music to the AEX.
    I tried with my library on a TimeCapsule & directly from my HDD and it seems the library on the TC cuts out more than the internal.

    I tried with two other identical sets of speakers bothw ere usb power and i used a usb power adapter to power them and they also exhibited the cut out.

    I tried another configuration; I wanted the AEX's to extend the range of the timecapsule (the latest 2009 model) ( and the AEX's are both 802.11n versions). and they simply do not work for AirTunes and sometimes do not appear in AirPort Utility.

    This is a really cool thing if it was solid and fixed up a bit.
  6. calderone macrumors 68040


    Aug 28, 2009
    I haven't had any issues with my AEX, except in a setup for a friend.

    I got his parents an Airport Express as they expressed an interest in music streaming. I added the AEX to their existing network and tested it out, the music would cut out. I inspected further an learned that they had a Linksys router... 802.11b.

    Needless to say, this turned out to be the problem. The Linksys simply did not have the bandwidth available. I created a direct link between a Macbook and the AEX and it performed fine for hours.

    Eventually I made the AEX their main router.

    Not saying this is the issues others are having. However, the experiences here match this particular experience of mine.
  7. Z06jerry macrumors regular

    Feb 2, 2008
    Ontario, Canada
    Try increasing your iTunes buffer to large.


    Attached Files:

  8. seadragon Contributor

    Mar 10, 2009
    That buffer setting is just for the incoming stream from the internet, not the signal being sent out to AirTunes.
  9. seadragon Contributor

    Mar 10, 2009
    My AirTunes is working flawlessly. I have the latest AEBS, and 3 AX units. The AX are set to join current network on the 5 GHz band. When I first set it up, I was getting random dropouts. I then changed the 5 GHz channel to 44 and its solid now, no dropouts at all. I had a New Years party at my place and DJ'd the thing from the iPhone. There was no break in the music all night.
  10. Z06jerry macrumors regular

    Feb 2, 2008
    Ontario, Canada
    Thanks for the info. Is there a way to increase the buffer size of the outgoing stream, perhaps through terminal?
  11. seadragon Contributor

    Mar 10, 2009
    Good question, I have no idea. :confused:

    Remember, a buffer is always on the receiving side of things and it required the use of memory. So in the case of AirTunes, it would have to be on the AirPort Express. As far as I know, the AX has no buffer. If it does, it's very small and not adjustable. If I have my computer speakers on and an AX running in the same room, there is a very very slight delay in the audio between them, but that has more to do with the signal traveling through the air. This leads me to believe that the AX has no buffer and simply outputs the signal it receives in real time.

    There is a multicast rate setting the AEBS, but that just sets the minimum signal quality required for a client to join it.

    One thing that will for certain cause dropouts is interference from other devices (cordless phones, next door neighbor etc.). Switching channels fixed it for me.
  12. bobr1952 macrumors 68020


    Jan 21, 2008
    Melbourne, FL
    Not totally related to this but thanks for the tip on airfoil, that is just what I have been looking for to port music from my Mac. I'll give it a try.
  13. waw74 macrumors 68030

    May 27, 2008
    There is a buffer, iTunes just takes this into account and delays both the local audio output and the information in the window to match what's coming out of the express. It also has to sync multiple expresses if you have them.
    I'm sure you made some engineers very happy (or sad) that it works so well that all their hard work to sync up the music has gone unnoticed.

    in the middle of a playing song, just click on and start another random track, check out the difference in time between when you're only on the computer (almost instant), and when you're using the computer and a remote speaker (a couple seconds).
  14. seadragon Contributor

    Mar 10, 2009
    Yeah, I have noticed that actually. Interesting.

    As far as dropouts go, I suppose it depends on the cause. If information is missing from the stream, then even a buffer wouldn't help. Unless there is error checking going on and the AEBS rebroadcasts the missing information.
  15. bollweevil thread starter macrumors 6502

    Feb 1, 2008
    My best configuration so far (still not 100% perfect):

    Set up the AirPort Express as "create new network". Choose 128-bit encryption (maybe 256-bit is too taxing, and maybe unencrypted is vulnerable to burden from leechers, or maybe it all makes no difference). Then choose the AirPort Express from the MacBook's Wifi menu. Then turn off Skype, turn off anything else that routinely uses the Wifi.

    Result: Often an entire album plays before the first glitch in the sound. Sadly, my shared Public folder is no longer visible on other computers in the house. This may be good when I am trying to listen to AirTunes, because it means less Wifi traffic, but it is bad when I want to watch a TV show off my computer from a different room. I may have to train myself to choose a different Wifi access point on my computer before I go to watch a TV show.
  16. slu macrumors 68000


    Sep 15, 2004
    Mine works great. I have an old Airport Express G model hooked to a new dual band Airport Extreme Base Station and it very, very rarely drops out. I'd suggest using a different channel. This makes a bigger difference than people think. So many people use the default channels that they can get bogged down.

Share This Page