Does anyone else have this issue with Mail notifications on Beta 2?

Discussion in 'iOS 8' started by KTK1990, Jun 18, 2014.

  1. KTK1990 macrumors 6502

    Dec 26, 2008
    I have an iPhone 5 (AT&T) and I upgraded to beta 2 last night from iOS 7.

    So far 95% of my things work but I am having one major issue and am wondering if anyone else has it or has a fix for it.

    I have multiple email accounts set up on my phone and on iOS 7 it worked fine, but after upgrading to iOS 8 beta 2 none of my emails notify me of a new email. I've gone into notification center and disabled everything and reneabled it but the issue is still there.

    The screen will not light up or make any noise when I receive a new email, I'll only find out when I go to the lock screen and see the notification or if I am using the phone, banners don't display and I only see due to the badge icon on the mail app.
  2. thesheleys macrumors member

    Oct 3, 2008
    I am having the same issue on an iPhone 5 on Verizon. If I reboot the phone I get them for a while then they stop working. I am using an iCloud Email account.
  3. grinny11 macrumors regular

    Aug 12, 2008
    I am having the same problem too with my iCloud account.
  4. KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    I do not get much mail on iCloud, but the emails I have on my phone are..

    AOL (Main, missed about 7 messages today)
    2x Gmail
    1 Hotmail (Xbox account)
    1 Microsoft Exchange account (College email address) (Missed 2 emails this morning)

    It feels to me like the mail app is stuck on Do not disturb mode, while all other apps notify me just fine (Like The Weather Channel and Messages).
  5. nanogirl21 macrumors 6502a


    Sep 20, 2011
    Midwest United States
    iPhone 5S Verizon and 4S Sprint are not getting mail notifications
  6. lotzosushi macrumors 6502


    Jan 10, 2007
    Same here. My Verizon 5 and 5S both don't show notifications, like fetch isn't working unless I go into the Mail app. Really annoying... been like that since Beta 1. But now with Beta 2 occasionally when I go to the Mail app on both LTE/Wi-Fi it'll keep popping up an error message saying I cannot get my mail. :mad:
  7. sbailey4 macrumors 68040


    Dec 5, 2011
    Same here in Verizon 4s. Get mail and the badge just no audio alerts.
  8. SixSlinger macrumors regular


    Jun 28, 2007
    I was having the same issue on my AT&T 5s and my Retina iPad mini. I toggled ALL the notification settings for each mail account, did a hard reset and now seems to be working. I had zero notifications coming through on b1, and the above trickery was done on b2.
  9. VSMacOne macrumors 601


    Oct 18, 2008
    I know this might not fix everything but you guys need to try a Reset of Network Settings or All Settings. It's like a magic button :)

    For a while my replies were all defaulting to the main email account and factory signature even though I had custom ones for each address. After a reset it all went back to normal.
  10. KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    I just tried a reset all and encountered some pretty weird bugs now.

    It seemed to remember some of the old settings (Like do not allow app X in notification center, or my default email is this address) but it doesn't let me disable LTE anymore and all languages but Chinese/Japanese/Korean in Siri settings say "(null)".
  11. lucien.dol macrumors newbie

    Jun 4, 2014
    Check Do not disturb

    You don't accidentally have Do Not Disturb turned on, have you? That happened to a friend of mine that had no alerts or notifications popping up...

  12. krypto909 macrumors member


    Jul 12, 2009
    I've act had that same exact problem since iOS 8 beta 1.
  13. grinny11 macrumors regular

    Aug 12, 2008
    Do. Not disturb is off. Getting all notifications but mail. It was vibrating but no banner or lock screen.

    Checked notification settings and noticed it was off. Turned it on. 10 min later, same thing. Turned it back on. Did this like three more times and now has stuck on and working fine.

    Weird how it disabled itself.
  14. KTK1990, Jun 20, 2014
    Last edited: Jun 20, 2014

    KTK1990 thread starter macrumors 6502

    Dec 26, 2008
    When you reset all settings by default in Notification center settings mail is set not to show you previews...

    Show in Notification Center - Off
    Noise - Ding
    Badge app icon - On
    Show on lock screen - Off
    Alert style - none
    Show previews - On

    I had everything on all accounts set to on and banner alerts, set them back on and will see if a reset all settings helped or not with that issue. I have my Do Not disturb set to Midnight - 4 am.

    Resetting settings helped with a texting issue (Predictive text moved the text entry box up, and that box blocked the view of some texts) but created new interesting bugs. Changed my background to what it should be and my folders didn't change... So I have a photo of a building with blue folders.

    Edit: After doing a Reset all settings, putting my settings back and then power cycling the phone, I received an email and the notifications did go off properly. It lit up the screen and dinged. Only issue I had is that I set my email to fetch once a hour to conserve battery life. I received the email at lets say 1 pm and the phone alerted me at 2:45.

Share This Page