Does anyone have dropbox working on DP2?

Discussion in 'Mac OS X Lion (10.7)' started by mrblack927, Mar 31, 2011.

  1. mrblack927 macrumors 6502a


    Aug 19, 2008
    I've been using Dropbox with no issues at all for ever since the first developer preview was released a month ago. Unfortunately, when I try to run it on developer preview 2 it opens momentarily then immediately quits.

    I even redownloaded the latest version from and applied the version fix... same result. It's not a big deal since it's not my primary machine but I use dropbox a lot for development purposes so it would be really helpful to get this working. Anyone else have better results?
  2. LutzRFrank macrumors newbie

    Mar 1, 2011
    runs fine here
  3. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    I had to manually start it. Usually starts at login, but no issues after starting.
  4. 3282868 macrumors 603

    Jan 8, 2009
    I installed the 1.1.1 update and modified the info.plist file in package contents to modify the bundle version from 1.1.1 to 2 (as before). Works perfectly. :)

    As does the new nightly builds of "Little Snitch"
  5. mrblack927 thread starter macrumors 6502a


    Aug 19, 2008
    Hmm, I don't know what I'm doing wrong then. I re-downloaded the latest forum build (1.1.7) and even unlinked my account to set it up again fresh. It just started to redownload all my files and then suddenly quit. Now when I open it up again it quits in a few seconds. It doesn't have a problem running setup and whatnot, but it crashes every time it tries to sync. :(
  6. funkyfresh69 macrumors member

    Mar 25, 2011
    Same problem here.

    even removing completely and then installing 1.1.7..

    I was just about to try changing the bundle version to 2.1.0 as i just read that fixes the issue..but then i tried one more time and now ist working? Bizzare..
  7. mrblack927 thread starter macrumors 6502a


    Aug 19, 2008
    Weird. After reading your comment I decided to try launching dropbox again (didn't change a thing) and now it's working. It must have been a server side bug on their end. Looks like they fixed it now. Cool! :D
  8. DeBilbao macrumors member


    Jan 13, 2008
    Latest forum build 1.1.9 running fine in the 2nd Developer's Preview of Lion.

    It was posted yesterday and you can download it at

    After installing it as any other program, you'll notice that Lion tells you can't run it because it isn't compatible with the operating system. You can get rid of the restriction by issuing this command in terminal app:

    defaults write /Applications/ CFBundleVersion 2.0
    Running fine an it's nicely translated into spanish.

  9. DeBilbao macrumors member


    Jan 13, 2008
    Not so fine... it closes unexpectedly and you need to restart it manually.
  10. saschke macrumors 6502

    Feb 2, 2008
  11. mrblack927 thread starter macrumors 6502a


    Aug 19, 2008
    Wow, they are cranking out versions fast. Why haven't they they updated it so that we don't have to apply the "version 2.0" patch then?
  12. Donut4000 macrumors member


    Aug 28, 2009
    Good old fashioned weirdness

    I've been trying to get dropbox working on DP2 here for a few days - thinking 1.1.9 with the version checked .plist would crack it. It didn't, as Dropbox would bomb after a few seconds. Separately, Time Machine won't load - the backup disk mounts - then nowt.
    Anyways - I pretty much resigned myself to waiting for more patches, when I tried Time Machine again an hour ago for kicks. It again didn't load - but instead <seemed> to log me out, and in again. This is when Dropbox fired up smiling, updated itself and has been happily sitting up there in the menu bar. Time Machine has gone back to its previously unresponsive state...
    I've done many reboots over the last few days - so I'm not sure why that wee episode made the difference it did.
    Well, that's one problem less I suppose :D:confused:

Share This Page