Does anyone have to wait a bit before system preferences opens?

WinterWolf90

macrumors 6502a
Original poster
Jan 18, 2014
606
419
Early 2015 Mac Pro here. It takes about 8 seconds to open up. I thought about doing a wipe of my computer, but didn't want to do it since I would have to reinstall everything and backup files from my external hard drive, but I thought about it to see if it helps system speed.
 

PieTunes

Contributor
May 6, 2016
743
1,045
San Diego, CA
Sometimes it can take a few seconds for System Preferences to open up for me. Happens on both my 2014 Mac mini and 2015 MacBook Air. I also do not have any extraneous icons in my preferences, just all the standard ones that come with a default installation. I have noticed though, at least for me, that the time it takes for System Preferences to show up seems to be directly proportional to how long it's been since I rebooted the machine. If I try to load them soon or within a few hours of rebooting, it takes several seconds. If it's the next day or a few days later, it comes up practically instantly.
 

leman

macrumors G4
Oct 14, 2008
11,513
6,011
8 seconds is certainly too long. Maybe you have some third-party pref panes installed which slow things down?
 

h9826790

macrumors G5
Apr 3, 2014
14,504
7,033
Hong Kong
I guess you mean a 2013 Mac Pro, there is no 2015 model. The Mac Pro didn't get any update for almost 3 years.

Anyway, 8 seconds is not right, by considering the Mac Pro's SSD speed. Even though after a cood boot, the system preference should easily pop up in 1-2 seconds. And for me, my system preference come up in less than 0.5 seconds.

I suspect you hit some bug, but don't know what it is.

e.g. All my apps loads fast, even photoshop, FCPX, they shows up quick. But it cost 8-10 seconds for Messages to open. I don't know why, only this one, and it wasn't like that few months ago, obviously something wrong. However, since I almost never close it, so it doesn't really a matter to me.
 
Last edited:

Gochugogi

macrumors regular
Oct 27, 2013
223
26
Sandwich Isles
Maybe use the OnyX app to clean system caches, non-working items, corrupt fonts, disk maintenance, etc. My 2013 Mini i7 (hybrid disk) blazes at opening the System preferences (less than a second).
 

MRxROBOT

macrumors 6502
Apr 14, 2016
488
422
1011100110
Mid 2015 rMBP here with no discernible lag in opening system preferences. Appears to happen instantaneous, if I were to measure it I would say less than a second from clicking on System Preferences to when it displays on my screen. 8 seconds is far too long.
 

WinterWolf90

macrumors 6502a
Original poster
Jan 18, 2014
606
419
I guess you mean a 2013 Mac Pro, there is no 2015 model. The Mac Pro did get any update for almost 3 years.

Anyway, 8 seconds is not right, by considering the Mac Pro's SSD speed. Even though after a cood boot, the system preference should easily pop up in 1-2 seconds. And for me, my system preference come up in less than 0.5 seconds.

I suspect you hit some bug, but don't know what it is.

e.g. All my apps loads fast, even photoshop, FCPX, they shows up quick. But it cost 8-10 seconds for Messages to open. I don't know why, only this one, and it wasn't like that few months ago, obviously something wrong. However, since I almost never close it, so it doesn't really a matter to me.


Mac Pro being MacBook Pro.


Thanks for all the replies.

I will try onyx to clean caches.
 

cynics

macrumors G4
Jan 8, 2012
11,630
1,907
System preference is the slowest opening "app" I have short of a couple games. 10+ seconds isn't uncommon, and even closing and immediately reopening takes 8+ seconds which I find really strange. I've been meaning to start diagnosing this just haven't felt compelled enough to do so.

OP: Let me know if you figure out something.
 

niji

Contributor
Feb 9, 2003
1,854
1,982
hokkaido
Maybe use the OnyX app to clean system caches, non-working items, corrupt fonts, disk maintenance, etc. My 2013 Mini i7 (hybrid disk) blazes at opening the System preferences (less than a second).

you would think that that might work. it doesn't. i have the same problem as original poster.
not 8 seconds, actually, just about 4 or 5 seconds, but it only started to be this way after updating to 11.4 (not just the current 11.5). at an apple store when i try demo models it takes about 2 seconds to open. 2 seconds is longer than it took before 11.4.
 

WinterWolf90

macrumors 6502a
Original poster
Jan 18, 2014
606
419
Update

I decided to just reformat my mac because I had a lot of stuff I didn't need on it anyway

It is working a lot faster now. The system preferences opens up in a second now.

Thanks everyone
 
  • Like
Reactions: MRxROBOT

MRxROBOT

macrumors 6502
Apr 14, 2016
488
422
1011100110
That's great.

As you reinstall everything on your MacBook, stop and check the System Pref load time between every install you do. This will potentially help you avoid getting back into the same predicament.
 

WinterWolf90

macrumors 6502a
Original poster
Jan 18, 2014
606
419
That's great.

As you reinstall everything on your MacBook, stop and check the System Pref load time between every install you do. This will potentially help you avoid getting back into the same predicament.


Thats a good idea; honestly i think it could have been flash; it was the only extra thing in the system preferences.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.