Does anyone know automator?

yuy

macrumors member
Original poster
Mar 27, 2005
62
0
Hi, I tried to build a workflow to download pdf files, starting with
'get current web page'-->
'get link url'-->
'filter url s.t. name ends with pdf'-->
'download url'.

The first time I run this workflow, it worked fine. But when I tried another webpage, it failed to download any pdf files. Does anybody know why?

I think the automator is quite buggy.
 

DXoverDY

macrumors 6502a
Apr 19, 2005
810
0
yuy said:
Hi, I tried to build a workflow to download pdf files, starting with
'get current web page'-->
'get link url'-->
'filter url s.t. name ends with pdf'-->
'download url'.

The first time I run this workflow, it worked fine. But when I tried another webpage, it failed to download any pdf files. Does anybody know why?

I think the automator is quite buggy.
i believe there's a bug in the "get link urls" portion of automator. i submitted a bug report for it and.. let me check..

I can indeed confirm that it's Get Link URLs from Webpages that is adding the extra http:// into the URL when the full path is not present.
it is marked as "Integrate" on the bug reporter page. You can use the "View Results" action to see how it's munging the relative links up. give it a try. Oh and the date I submited it
Created Date: 04-May-2005 01:34 PM

it's been on "Integrate" for about 2 months now.
 

yuy

macrumors member
Original poster
Mar 27, 2005
62
0
So it is buggy and not solved?

How do you display the result of action 'get link url from webpage' ? Through log, I can only see the rough information of process.

And are there automatro actions for Camino or Opera?
I like this atumator function very much, you know, but it is not accompolished yet. hehe :eek:
 

DXoverDY

macrumors 6502a
Apr 19, 2005
810
0
yuy said:
So it is buggy and not solved?

How do you display the result of action 'get link url from webpage' ? Through log, I can only see the rough information of process.

And are there automatro actions for Camino or Opera?
I like this atumator function very much, you know, but it is not accompolished yet. hehe :eek:
there are no actions for Opera or Camino yet. The application authors would have to write them, if you want those features, i'd recommend emailing and putting your support in the pot.

You can see the actions by searching for "View Results" in the automator window's search. you just stick it wherever you'd like and it'll starts pitting out the results from the previous action. you start getting results like "http://http://address.com/path/filename.ext

notice the double http://? hence the reason it won't download anything probably. your issue might be different but i suspect it's not.
 

yuy

macrumors member
Original poster
Mar 27, 2005
62
0
hehe, good point

i tried 'view result'
and after the 'get link url', the result is '{}'

quite tricky