Does anyone know how to fix this display problem?

Discussion in 'iPod' started by kusanagi, Sep 9, 2007.

  1. kusanagi macrumors regular

    Joined:
    Jun 18, 2007
    #1
    Hello!

    Well just my luck, i'm just about to sell off my iPod to get an iPhone and i just dropped it! Now its got this weird thing on the screen but only when the backlight it on. It doesn't happen when the backlight is off, its only visible at all when the backlight is on.:confused: I was thinking that there might be a hairline crack with the polarised layer of hte lcd but then it should be appearing in all stages of light. I was also thinking that there might be a crack with the light diffuser and that the refraction of light was causing this but i'm no expert.

    Anyone have any ideas? Below are pics when its off, when its on with no backlight and then when its on and the backlight is on.

    Thanks in advance.
     

    Attached Files:

  2. Draythor macrumors 6502

    Draythor

    Joined:
    Sep 12, 2006
    Location:
    Exeter University, UK
    #2
    Have you tried the usual? Reset, Restore, Re-install?
    If so, does this appear when the iPod is being used normally? or just when connected?
     
  3. kusanagi thread starter macrumors regular

    Joined:
    Jun 18, 2007
    #3
    Yeah tried the reset etc, doesnt work.

    It happens all the time, actually i even tried running it for the whole day playing videos if it was the pixels that needed to be massaged out if you know what i mean.
     
  4. Draythor macrumors 6502

    Draythor

    Joined:
    Sep 12, 2006
    Location:
    Exeter University, UK
    #4
    Bummer. Have a third party repairer look at it. There's pleanty of them out there. They'll do it much cheaper than Apple and they're less likely to break the iPod/frazzle themselves than you are. I had my Nano 1G's Screen replaced a couple of months back.
     

Share This Page