Does anyone notice that iPad appstore keeps asking for password?

Discussion in 'iPad Apps' started by yalag, Apr 16, 2010.

  1. yalag macrumors 65816

    Nov 18, 2007
    Every time I launch the appstore it forgets my password and reasks it. It's not even when I try to download something, it asks as soon as I launch the appstore. Same goes for ibook store etc. Is this normal? Anyone else experience this?
  2. GoCubsGo macrumors Nehalem


    Feb 19, 2005
  3. yalag thread starter macrumors 65816

    Nov 18, 2007
    I'm sorry im supposed to read each post of each page of each thread in this forum before posting. Not to mention i cant even find anything relevant in the post you linked....
  4. WERA Cannoli macrumors newbie

    Apr 3, 2010
    Where in that thread is the iTunes Store password issue mentioned? You link to page 2 of 18 pages.
  5. Tech-Boy macrumors regular

    Mar 1, 2010
    My iPad isn't here yet, but it does the same thing on my ipod touch. I believe it is for security purposes so that someone (friend/thief), cannot open the appstore and start downloading as many apps as they want.
  6. Peace macrumors Core


    Apr 1, 2005
    Space--The ONLY Frontier
    Anybody ever think it might be asking for your password because it doesn't have user accounts ? This way your kid brother wouldn't be able to buy an app.;)
  7. wingnut8 macrumors 65816


    Jun 8, 2007
    Same as the iPhone. Not sure why it's a surprise to anyone.
  8. gwynne macrumors 68000


    Mar 11, 2010
    I believe this is working as intended. A lot of people have it set up so that typing that password is the only thing between the device and their credit card. I.e., nothing is stopping someone else from getting ahold of your device and buying a $200 medical app.
  9. Runt888 macrumors 6502a

    Nov 17, 2008
    Once you type in your password, it will remember it for a short period of time. Once it times out, you will have to enter it again the next time you download something. As others have said, it's probably a security thing so someone who picks up your device can't go buy a bunch of stuff.

    It seems to be around 5 minutes, but I've never done any real testing to confirm an exact time.
  10. macduke macrumors G3


    Jun 27, 2007
    Central U.S.
    I don't think anyone here actually read the OP. He has this problem when ENTERING the app store, not just when installing something. That could get real annoying.

    As for a solution: I used to have this problem on my iPhone from time to time. Sometimes it is the result of an app not fully downloading from the App Store because of some sort of error that occurred in processing the transaction. When you tried downloading an app in the past did it give you a warning message saying you might want to try downloading it from iTunes on a computer? Sometimes that can cause the thing to loop the password box. First try hard-resetting the device (hold home and sleep/wake button for 10 seconds). If that doesn't work, and you can remember which apps you installed around the time of the error, try reinstalling those from an iTunes sync if possible. Heck, an iTunes sync alone could potentially fix the problem, without replacing the apps. I can't fully remember what caused it to go away for me, but these are a few of the things I remember trying.
  11. smithrh macrumors 68020


    Feb 28, 2009
    This is actually good

    I used to be really annoyed at this - until a Touch that I had given to someone was stolen. Said Touch was last sync'd by me, so it was my account that was stored on there.

    If it didn't ask for a password, the thief could have helped themselves to anything - movies, songs, apps....
  12. noah82 macrumors 6502a


    Oct 16, 2008
    San Diego, CA
  13. UCF Sam macrumors regular

    Mar 4, 2010
    No, its a bug. I've experienced what he's talking about on the iphone, but haven't on the ipad yet. Its in no way a security feature, because if he presses cancel it still lets him into the app store. If he puts in the password it will still ask him for the password again when he downloads something. The app store is supposed to ask you for your password, but only when you download something. After you make a download using the password, it will let you reopen the app store and download again without using the password for a few minutes, IE if you download 2 apps in a row you wont have to enter your password twice.

    From my experience, this problem comes up when a app fails to download correctly and has to be deleted from the springboard. The problem seems to go away on its own after awhile though (maybe from syncing or resetting)...
  14. UCF Sam macrumors regular

    Mar 4, 2010

    Beat me...
  15. mcdj macrumors G3


    Jul 10, 2007
  16. DaBrain macrumors 65816


    Feb 28, 2007
    ERIE, PA
    I agree Gwynne and Im glad that it works that way. With the amount of apps on the store, one can only imagine your own iPad stolen or in some little brother/sisters hand etc.... Now that could be a Nightmare if it always remembered your PW. Yikes! :eek: ;)

    Note: Just saw UCF Sam's post and your right I/we didn't read the post correctly. I agree if he/she is not even d/l an app but just starting up the Store App or like they stated going to the book store and it's asking for their PW right then and there, then yep something is not right. Wonder why some have this issue and others don't? weird? Hope they fix that, as that would be a pain in the duppa!
  17. gopherhockey macrumors regular


    Apr 2, 2010
    I have this same problem. Its never done this on my iPhone and only just started on the iPad. Its definitely not security related or by design.

    The hard reset didn't fix it.. so hopefully it will go away on its own soon. I go into the app store a lot looking for updates and new apps... it would be like safari prompting for a password every time you use it.

    I'm pretty sure I had some recent updates get interrupted as I was traveling in Europe where we had spotty coverage so no doubt something about this caused it. Wish there was a way to figure it out.
  18. orlandocano macrumors regular

    Apr 23, 2010
    It's happening to me too, op.. Sorry that i don't have any productive suggestions to add at the moment.. Just wanted u to know that it looks like a bug that is affecting several ppl and is not just sometningn wrong with your iPad and account...
  19. spy008 macrumors newbie

    May 17, 2010
    check your itunes downloads

    this problem is caused by having a pending download in iTunes. when this happens go into itunes and check your downloads queue. once you have downloaded whatever it is it'll stop til the next time you have a download.
  20. surferchick2 macrumors member


    Nov 23, 2007
    Fidalgo Island, WA
    Mine's doing this also. I have no pending downloads in iTunes or any apps that appear to be hanging (not greyed out and no status bar). I've done a hard reset, synched, and worked with my settings. I even deleted my podcasts, books and some recreant apps to no avail. I don't have this problem with my iPhone and my husband's iPad doesn't do this either.
  21. Batt macrumors 65816


    Dec 17, 2007
    Syracuse, NY
    An app you deleted from the iPad is still in iTunes. Kill it and resync. You'll be fine.
  22. thedarkhorse macrumors 6502a

    Sep 13, 2007
    I'm getting this too, it went away last night when I opened itunes and I thought a download maybe finished. But now today this issue is back again. At least I don't have to type in my password, I can just click cancel on the notification and browse the app store just fine, but I would rather not be asked until I actually buy something.

Share This Page