Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Does Apple Mail still open up in split screen view randomly?

nbnbxdnb

macrumors regular
Original poster
Sep 1, 2010
244
17
This has been a all new annoyance introduced to Mail app in Mojave. IT will pop up randomly in split screen view when there is an app in full screen mode. I have searched and couldn't find a way to stop that. So I just wonder if this still happens in 10.15. It could be a reason for an early upgrade.
 

nbnbxdnb

macrumors regular
Original poster
Sep 1, 2010
244
17
Still happens all the time, even on clean install.
OK. I already filed a bug report.But who knows when it got fixed. I have been using Apple Mail for years. Maybe it is finally the time to look for another email client.
 

NecRosex

macrumors member
Jul 16, 2019
36
15
babyLon
Problem still persists as of the latest beta, Mail.app keeps opening randomly. No idea how to stop it.
 

cambookpro

macrumors 604
Feb 3, 2010
6,885
2,626
United Kingdom
I have this problem too. Was enough to try and switch to Airmail, but I'm having syncing problems with that. There seems to be no perfect solution!

Are you using a Gmail account? I find that it doesn't seem to do it if I delete it from Mail.
 

NecRosex

macrumors member
Jul 16, 2019
36
15
babyLon
I have this problem too. Was enough to try and switch to Airmail, but I'm having syncing problems with that. There seems to be no perfect solution!

Are you using a Gmail account? I find that it doesn't seem to do it if I delete it from Mail.
Yeah my primary is iCloud mail, but I do have a gmail as my secondary.
 

cambookpro

macrumors 604
Feb 3, 2010
6,885
2,626
United Kingdom
Yeah my primary is iCloud mail, but I do have a gmail as my secondary.
I can't remember for the life of me where I read this, but do you have Calendar enabled on your Gmail account in System Prefs > Internet Accounts? I seem to remember somebody saying this bug doesn't happen if you do, but have never tested it myself. Might be completely wrong.

In any case, this bug is listed as having 'More than 10' recent reports in Feedback Assistant, so hopefully they are aware of it. Doesn't bode well that it's been around for so long without already being fixed, however.
 

NecRosex

macrumors member
Jul 16, 2019
36
15
babyLon
I can't remember for the life of me where I read this, but do you have Calendar enabled on your Gmail account in System Prefs > Internet Accounts? I seem to remember somebody saying this bug doesn't happen if you do, but have never tested it myself. Might be completely wrong.

In any case, this bug is listed as having 'More than 10' recent reports in Feedback Assistant, so hopefully they are aware of it. Doesn't bode well that it's been around for so long without already being fixed, however.

Everything apart from the mail itself is disabled. I don't like Google, I would never use any of their stupid joke calendars. I doubt it would make any difference though, I deleted and re-added my gmail account. The next time Mail.app pops up I'll enable the calendar thingy, but I'm 98% sure it won't help as most people who have a gmail account also have the calendar enabled, and yet... the issue persists :D
 

nbnbxdnb

macrumors regular
Original poster
Sep 1, 2010
244
17
Where is this "option" to turn this annoying problem off?
Yes. See attached screenshot. But from my experience the option doesn't work.
Screen Shot 2020-03-10 at 9.23.24 PM.png
 

StarShot

macrumors 65816
Mar 31, 2014
1,000
369
Yes. See attached screenshot. But from my experience the option doesn't work.
View attachment 898510
Somehow I missed that option which I've now "checked". Earlier today before I replied to this thread, I selected the 2nd option from the top (Check for new messages). I think my option before was every 5 minutes thinking that was what was causing the annoying message popup. I've now selected "manually", hoping that will cure the "popup".

I also notice that my "default email reader" is Opera which I don't remember selecting. Does that mean anytime I'm reading a message, I'm using Opera?
 

lolasher

macrumors newbie
Aug 1, 2014
29
5
The problem is with gmail automatic integration, when configured manually as smtp it doesn’t occur.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.