Does iTunes 12.6.3 work with iOS 11.3

Discussion in 'iOS 11' started by saudor, Mar 28, 2018.

  1. saudor, Mar 28, 2018
    Last edited: Mar 30, 2018

    saudor macrumors 6502a

    Joined:
    Jul 18, 2011
    #1
    Has anyone tried restoring an iphone8 / x device under 11.3 with iTunes 12.6.3? What about non iphone8/x devices such as iphone 7, older ipads, etc that didnt ship with iOS11.

    Thanks!


    P.S. if you try this, dont forget to backup your old 11.2.x backup somewhere. Otherwise, it might overwrite it and you wont be able to get back to 11.2.x


    EDIT:
    IPAD AIR 2: Restore from backup and sync seems to work fine. I was able to transfer an app through it. Running Sierra 10.12.6 and itunes 12.6.3. However, you will need some other way to get iOS11.3 (i.e. OTA or using iTunes 12.7.3 on another partition, VM, etc) on the device as iTunes 12.6.3 flat out refuses.

    EDIT 2: OK. so the restore from backup seem to have "deleted" some apps randomly.. and those apps get stuck in the loading 2/3 of the way. Normally, this is where iTunes would start syncing apps onto the device after the restore. It's just hanging. Doesn't look too good.

    You can also write to Apple here. If enough people "complain", they may release 12.6.4 to solve this issue.
    https://www.apple.com/feedback/itunesapp.html

    sample message: #35
     
  2. Paddle1 macrumors 68040

    Joined:
    May 1, 2013
    #2
    My iTunes 12.6.2 works as normal with 11.3 so 12.6.3 should be fine.
     
  3. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #3
    Older devices should be just fine. iPhone 8 or above I don’t know. But Apple says iTunes 12.6.3 for business has added support for new device while maintaining the old feature set that business user needs. But in terms of iOS 11.3, you don’t need to worry that part,
     
  4. hideous cheese macrumors regular

    Joined:
    Feb 8, 2012
    #4
    I'm getting a message that I need to update to iTunes 12.7.3 to access iOS 11.3 for both iPhone 7 and iPad Air 2

    I have a boot partition with the newer version on so could update via that (going to do a restore so OTA is no good)
     
  5. Paddle1 macrumors 68040

    Joined:
    May 1, 2013
    #5
    Which version of iTunes are you running?
     
  6. hideous cheese macrumors regular

    Joined:
    Feb 8, 2012
    #6
    12.6.3.6 - the special version that saved the app store
     
  7. Foxglove9 macrumors 68000

    Foxglove9

    Joined:
    Jan 14, 2006
    Location:
    New York City
    #7
    I can no longer update my devices via iTunes on my Mac anymore either unless I date my iTunes to 12.7.3 it says. If anyone has updated their iOS to 11.3 does it still work and sync with iTunes 12.6.3?
     
  8. Bazonga macrumors newbie

    Joined:
    Nov 29, 2012
    #8
    No joy, sync between iOS 11.3 and iTunes 12.6.3 doesn't work!
     
  9. Foxglove9 macrumors 68000

    Foxglove9

    Joined:
    Jan 14, 2006
    Location:
    New York City
    #9
    Well that's just wonderful :(
     
  10. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #10
    No issues with access to my 6S/6S+/Air 2/1st Gen iPP 12.9 with iTunes 12.6.3.6 for updates, backups, installing or moving compatible apps. iTunes is installed on a 2012 Mini Server, iOS devices connected via stock Lightening cable connected to wired Apple Extended Keyboard.
     
  11. saudor thread starter macrumors 6502a

    Joined:
    Jul 18, 2011
    #11
    ugh. this is annoying. there are so many times when an app update breaks something (or add ads) and i need to go back to the previous version
    --- Post Merged, Mar 29, 2018 ---
    really? i guess i'll test it out.. while they're both being signed and copy my 11.2.6 backup on my external
     
  12. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #12
    I am having the same problem for an iPhone 7 and X. Does anyone have a solution? Very disappointing!
     
  13. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #13
    I haven't tried a restore but backup and sync are working fine between an iPhone 8, iPad Pro 9.7, and and iPod Touch 6th gen. The system is 10.13.3, iTunes is 12.6.3.6. All the iOS devices are on 11.3.
     
  14. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #14
    chrfr,

    were you able to download 11.3 on iTunes 12.6.3.6? I am getting the message that I have to upgrade to iTunes 12.7.3 to download the 11.3 update?
     
  15. saudor thread starter macrumors 6502a

    Joined:
    Jul 18, 2011
    #15
    im gettng this too. Gonna do OTA and see if i can sync and then do a restore on my Air 2 first
     
  16. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #16
    Please share with us if the restore works on your Air 2 after the update to 11.3. Thanks
     
  17. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #17
    I did OTA updates on all these, sorry.
     
  18. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #18
    thanks for letting us know. So if we need to do a restore in the future sticking with iTunes 12.6.3.6, we might be screwed if when have iOS 11.3 or higher
     
  19. wagonfixin, Mar 29, 2018
    Last edited: Apr 3, 2018

    wagonfixin macrumors newbie

    Joined:
    Sep 26, 2017
    #19
    Dowloaded the IPSW firmware files here, used iTunes version 12.6.3.6 to [Option Update] to successfully upgrade to iOS 11.3 on both iPad 10.5 and iPhone X.

    Unfortunately, after the upgrade to iOS 11.3 and iPhone X reboot, iTunes reports "This iPhone 'iPhone X' cannot be used because it requires iTunes 12.7.3 or later. Would you like to download the latest version of iTunes now?". Note that while iPhone X works fine, it no longer connects to iTunes 12.6.3, offering the above error as the way forward.

    iPad 10.5 works fine under iTunes 12.6.3.6 (sync & apps) with iOS 11.3, iPhone X on 11.3 is unable to connect with iTunes 12.6.3.

    UPDATE: Apple released an updated iTunes 12.6.4 on 3 Apr which has resolved the connectivity and sync issues with iPhone X under iOS 11.3. iTunes 12.6.4 continues to provide the necessary backup, app-management and content-sync functionality that was lost under the newer stripped-down music focused version of iTunes (12.7.x).
     
  20. saudor, Mar 29, 2018
    Last edited: Mar 29, 2018

    saudor thread starter macrumors 6502a

    Joined:
    Jul 18, 2011
    #20
    Restore from backup and sync seems to work fine. I was able to transfer an app through it. Running Sierra 10.12.6 and itunes 12.6.3. However, you will need some other way to get iOS11.3 (i.e. OTA or using iTunes 12.7.3 on another partition, VM, etc) on the device as 12.6.3 flat out refuses.

    iPad Air 2

    EDIT: there are some issues. Apps dont "sync" back and get stuck
     
  21. Paddle1 macrumors 68040

    Joined:
    May 1, 2013
    #21
    Just tried to update to final 11.3 from beta 11.3 on 12.6.2 and got stopped by something like "The device could not be updated. An unknown error occurred. (14)"

    I'm going to try updating to 12.6.3.
     
  22. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #22
    Thanks for the update. I am very disappointed with the restrictions Apple placed on this update. Hope that if enough people complain they will let 12.6.3 support this iOS update with a small update to iTunes with having to install 12.7.3 or 4
     
  23. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #23
    iPhone 6s plus has no problem to sync music and itunes 12.6.3 does recognises the iphone. It seems that iPhone X/8 is the only iPhone that is requiring iTunes 12.7 or above with iOS 11.3.
     
  24. ET007 macrumors member

    Joined:
    Nov 11, 2009
    #24
    Updated to the most recent High Sierra update that come out today. I am able to sync my iPhone X with iTunes 12.6.3
     
  25. MacGarage, Mar 29, 2018
    Last edited: Mar 30, 2018

    MacGarage macrumors member

    Joined:
    Jun 18, 2017
    Location:
    Ohio
    #25
    I had to download 11.3 via my iPhone 7 and iPad Air 2.

    I was able to sync and update apps fine afterward.

    Just concerned about restoring if that happens.

    I noticed the new version of Configurer 2 also requires iTunes 12.7.x.

    Been debating about moving to iMazing.
     

Share This Page