Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
I signed up for iTunes Match on my MBP about a week ago. I started switching out my imported music (99% from CDs) to matched versions.

Sunday while driving to work I went to play some music from my iPhone and it skipped through a lot of them while giving me a download icon thing. It looks like the only songs that are working are ones I purchased or got free (Starbucks App) from iTunes.

Any idea what's causing this and how to fix it? For me, it's looking like iTunes Match is not a good buy.

In the picture I have Airplane Mode on to see if it's checking iTunes to make sure the song is legal. Even with iPhone connected to Wifi I cannot play this music. In iTunes I have it checked to sync all my music to iPhone and it's taking up a large amount of space.
 

Attachments

  • IMG_2669.PNG
    IMG_2669.PNG
    511.4 KB · Views: 139

impaler

macrumors 6502
Feb 20, 2006
447
10
FL
iTunes Match requires a network connection, as it streams music. Alternately, you can download individual songs/albums to play offline.
 

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
iTunes Match requires a network connection, as it streams music. Alternately, you can download individual songs/albums to play offline.

I have everything stored locally on my MBP and that is supposed to be synced to my iPhone. On iPhone I have iTunes Match turned off. Does it need to phone home to ensure I'm still paying for the service before playing?

I don't think I had this issue before upgrading to iOS 8, although I only had it a day or so before then. I've thought of doing a clean install of iOS, might that help?
 

Rigby

macrumors 603
Aug 5, 2008
6,055
9,929
San Jose, CA
I have everything stored locally on my MBP and that is supposed to be synced to my iPhone. On iPhone I have iTunes Match turned off.
If you want to see your Match library on the phone, you need to turn on iTunes Match. This will automatically disable music syncing via iTunes and USB cable. Once you have done that, you can either stream the songs (which obviously requires an Internet connection) or download them to the phone by tapping the little cloud icon next to the items.
 

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
I don't want to stream the music from the cloud on my iPhone. I want them stored locally. According to iTunes and the Usage on iPhone, I have about 11 GB of Music on my iPhone. This is how big my library is. I just can't access the files on my iPhone.

Here's some more information...

Ace in the Hole is an original AAC File
Accidental Mambo is a Matched AAC
All My Exs Live in Texas is an original AAC File

Ace in the whole is accessible on my iPhone. The other two aren't. So file type doesn't seem to make a difference.
 

Rigby

macrumors 603
Aug 5, 2008
6,055
9,929
San Jose, CA
According to iTunes and the Usage on iPhone, I have about 11 GB of Music on my iPhone. This is how big my library is. I just can't access the files on my iPhone.
Can you see your music when you go to Settings/General/Usage/Manage Storage/Music on the phone?
 

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
Can you see your music when you go to Settings/General/Usage/Manage Storage/Music on the phone?

I've been messing around with it for a while. At the time of the postings, there was no Music on there. Right now there's still nothing on there, the Music App is showing to download from the Cloud all my purchased music, and iTunes shows 31 Songs at 322.7 MB. I don't know what that is.
 

Rigby

macrumors 603
Aug 5, 2008
6,055
9,929
San Jose, CA
I've been messing around with it for a while. At the time of the postings, there was no Music on there. Right now there's still nothing on there, the Music App is showing to download from the Cloud all my purchased music
This is normal if you have "Show all music" enabled and iTunes Match disabled.
and iTunes shows 31 Songs at 322.7 MB. I don't know what that is.
I'm confused. Previously you wrote that iTunes shows 11GB of music? Just disable "Show all music" and you will only see what's on the phone in the Music app.

If all else fails, delete all local music under Usage/Music (swipe left and delete). Then sync again with iTunes.
 

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
I'm confused. Previously you wrote that iTunes shows 11GB of music? Just disable "Show all music" and you will only see what's on the phone.

Sorry, forgot to say I have deselected Music to sync via iTunes. This leaves me two songs. Ain't That a Kick in the Head (bought that, I think I have it set for someone's ringtone or alarm) and Airstream Driver (I'm assuming I got free somewhere along the line). I am not given the choice to delete them.
 

davidg4781

macrumors 68030
Original poster
Oct 28, 2006
2,632
318
Alice, TX
Ok, I think I found where iTunes is getting these 31 songs from. Now how do I delete them? And what's weird is the Harry Connick, Jr. ones are 128 kbps. I purchased these through iTunes and they should've downloaded 256 kbps. This is what is in my iTunes Library.

Is this the part where i need to go over to the iTunes or iOS forum?
 

Attachments

  • Screen Shot 2014-09-22 at 8.41.11 PM.png
    Screen Shot 2014-09-22 at 8.41.11 PM.png
    484 KB · Views: 127
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.