Does mail.app support push for gmail?

Discussion in 'macOS' started by zorahk, Aug 30, 2009.

  1. paulyras macrumors 6502

    Joined:
    Dec 3, 2006
    Location:
    Singapore
    #2
    I don't know the formal answer (though a curious), but did see that you can poll the servers in 1 minute intervals. I think that's new, and definitely good.
     
  2. Drewsky87 macrumors 6502

    Drewsky87

    Joined:
    Dec 5, 2008
    Location:
    MD
    #3
    That was in Leopard if I'm not mistaken.
     
  3. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #4
    If you are connecting to GMail through IMAP then on the Advanced page for the IMAP account preferences, there is an option called:

    Use IDLE command if the server supports it.

    This should work for GMail. Might need to restart Mail for he changes to take effect. Basically this keeps a connection open and you get mails instantly.

    One side effect that doesn't look like it's fixed in SL, is that when you use the IDLE command, you don't get the audible notification when new mail arrives (the dock badge does still update). I opened another thread on this:
    http://forums.macrumors.com/showthread.php?t=776312

    Is this what you mean by push?

    -Kevin
     
  4. paulyras macrumors 6502

    Joined:
    Dec 3, 2006
    Location:
    Singapore
    #5
    You may well be right. I had played around with mail in leopard, but had dropped it as I just rolled everything in with my work mail. Now with sl, I've come back. I'm pretty sure I would have stuck with mail.app if I had seen that previously, but likely just missed it.

    Thanks,

    p.
     
  5. GroundLoop macrumors 68000

    GroundLoop

    Joined:
    Mar 21, 2003
    #6
    POP GMail in Mail 4.0

    I am also having issues with Gmail and Snow Leopard. I do not want to use IMAP settings. Therefore, I logged into Gmail and disabled IMAP (because Mail 4.0 defaults to IMAP). THis causes the setup to fail and allows me to set up the account manually.

    I select POP set the server to pop.gmail.com
    I enter the email address and password
    then I set up the SMTP server (smtp.gmail.com)

    Now, I can send email, but I cannot receive gmail via Mail 4.0.

    Is anyone else having this issue?

    Hickman
     

Share This Page