Does not boot from hard drive after OS X install

Discussion in 'macOS' started by samwinch, Nov 4, 2011.

  1. samwinch macrumors newbie

    Joined:
    Nov 4, 2011
    #1
    I'm new to Macs..... So I only have an old Powerbook G4. I'm trying to learn Mac OS X, mac hardware, etc....I installed Leopard there first and it booted from the hard drive...But it was very slow. So decided to install Tiger and found bootable tiger retail full version. When Install tiger using that ....installation process completes successfully and restarts. at that point it does not detect the hard disk as a bootable device...Checked hard disk with Disk utility and it says hard drive is "ok". So I tried re-installing Leopard and now I get the same problem with that too. Could someone please help me out here..Thanks you in advance.
    :confused::confused::confused:
     
  2. samwinch, Nov 4, 2011
    Last edited: Nov 4, 2011

    samwinch thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #3
    Thanks a lot for the quick reply.
    I must says these stuff before going through the suggestions. Here I haven't change any hardware. these hardware worked with Leopard , but very slow.

    I tried all given options (SMC,PRAM, safe boot) other than booting from the cd came with the powerbook [I didn't get it when I'm buying it :( ], booting from external install. But finally I did format and installed it, formatted with zero one pass and install, no luck with those and when ever I boot ...question mark is there!...

    When I press the Option key...I only get a blue screen, black cursor, and buttons ( I think Refresh, enter)..That is it. When Tiger DVD in there it shows the boot option of Tiger DVD.

    I tried one thing which I didn't earlier according to the suggestions. "Repair disk permissions".That returns an error.

    "First Aid Failed" - Error : No valid packages

    Since I had doubts,,,I connect this hard drive to a linux machine and check it. Linux didn't show any data and gParted(Partition Manager) didn't show any partitions either.... ! I don't know what that means...Thought of posting it...

    Oh...one more thing...I formatted this hard drive using linux one time.....But after that I formatted it several times using Disk Utility. Could that be a problem????

    Any suggestions would be highly appreciated.
     
  3. samwinch thread starter macrumors newbie

    Joined:
    Nov 4, 2011
    #4
    Finally found the solution myself

    I'm writing this ....to help someone whose looking to fix a similar issue.

    Even though the installations (Tiger, Leopard) completed, Could not boot the powerbook G4 using the hard drive. I checked the hard drive using Linux and there are no files on the hard drive. So that means files not being written while the installation. So it should be a issue of the main board or the hard drive itself. Since I have came across a similar issue some time back with a windows based computer I just switched the hard drive and there you it works great. So I was dealing with a faulty hard drive!!!

    Hope this will help someone :):) Thanks a lot for the help "simsaladimbamba"
     

Share This Page