Does not recognize external hard drive

fyrebyrd3

macrumors newbie
Original poster
Mar 21, 2012
6
0
Hi,
I have a Toshiba 750GB external hard drive that I'm trying to use as a back up drive. When I plug it into my MacBook Pro (bought it maybe 2 weeks ago), it won't mount in the finder or the disk utility. If I plug the hard drive in to any other computer, it mounts no problem. Just not this one. I tried booting into safe mood and then restarting, I checked the permissions in my finder and it should be visible, I looked for it in disk utility but it doesn't show up there. It even shows up in my old MacBook Pro from 2009 which is also running Lion. Just not this one. Please help!!!

Updated: Weirdly enough, it shows up in my system profiler. But nowhere else.
 
Last edited:

fyrebyrd3

macrumors newbie
Original poster
Mar 21, 2012
6
0
So it doesn't show up on this machine at all, but I formatted it as Mac OSX Journaled on my other machine.
 

fyrebyrd3

macrumors newbie
Original poster
Mar 21, 2012
6
0
So I don't know if this helps anyone, but I have apple care and when I took it in today, they said that the new laptops have two states in terms of power output, high and low and that for USB powered devices like my external hard drive, the computer needs to be in the high state. For whatever reason, it refuses to move to the high state (and apparently there is no way to force it to go there), and so the external hard drive can't draw enough power to mount itself.

Solution suggested by them: Buy a different external hard drive.
 

TheAppleSource

macrumors regular
Mar 9, 2012
158
0
United Kingdom
This definitely seems relevant to your situation. Looks like it could well be the same hard drive as yours (Toshiba, 750GB) and they also say that it's a power problem.

One of the suggestions there is to get a Y connector (as in a USB cable with two USB ports at the end, so it can give power from two ports as opposed to just one). This should hopefully mean that you can still use the hard drive and not have to get a new one.
 

amuro88

macrumors newbie
Jun 30, 2012
1
0
Solution

I had the exact problem, luckily I have another Toshiba drive (2tb) which is powered by a wall outlet and doesn't only rely on usb power, i swapped cables with it (usb 3.0) and I got the 750gb Toshiba drive to work, the problem is the cable. The one that comes stock with the toshiba drive doesn't and wont work on the new macbook pros because of the usb cable is not a high current cable (if thats what its called?) try finding another usb 3.0 cable to fit the drive and it will most likely work.

Hope this helps
 

dacoolest

macrumors regular
Nov 11, 2011
184
0
I had a similar problem, my mac was not recognizing my external HDD. I've made few threads to get help from the forums. In the end I got my problem solved by buying a new external HDD.
 

fyrebyrd3

macrumors newbie
Original poster
Mar 21, 2012
6
0
So I got an answer when I took it in. On the new macbook pro apparently there is a high energy output state and a low one for the USB ports and there is no way to manually switch between the two. It turned out my cord was defective and wasn't sending the appropriate signal to the computer to switch into the higher powered state and, in the lower power state, it didn't give the drive enough energy to properly mount. A new cable fixed all my problems. Thanks for all the help!
 

PatricioC

macrumors newbie
Jul 14, 2012
1
0
new on Apple

well I was having some issues with my new Mac due to my inexpirience, mac hard drives are very different of what I was used to, can anyone give some tips for the future?
 

Coheno

macrumors newbie
Oct 14, 2011
3
0
So I got an answer when I took it in. On the new macbook pro apparently there is a high energy output state and a low one for the USB ports and there is no way to manually switch between the two. It turned out my cord was defective and wasn't sending the appropriate signal to the computer to switch into the higher powered state and, in the lower power state, it didn't give the drive enough energy to properly mount. A new cable fixed all my problems. Thanks for all the help!
I'm having the exact issue with my new MBA and my old WD passport, which works on my old Macs. What kind of cable did you buy?
 

fyrebyrd3

macrumors newbie
Original poster
Mar 21, 2012
6
0
I bought one of those USB Y cables - so it has 2 USB ports on one end and then whatever connector you need to plug into your hard drive on the other. With both USB plugged in to the computer can pull enough power to run itself.

Good luck!!
 

fletchwiley

macrumors newbie
Jun 24, 2013
1
0
HD won't show up

I have a 300GB Fantom drive (firewire) that I have been using for my time machine backup. It isn't showing up anywhere. I have a 2.6 GHz Macbook Pro running version 10.6.8 with 4 GB of RAM.

There have been times when it fills up and I just erase everything on it and let it run again.

Any clues as to what I should do??

Thanks,

Fletch Wiley
Austin, TX
 

rayyanthameem

macrumors newbie
Jul 19, 2013
1
0
i'v the same problem,but i'v 1tb toshiba hdd, i found the solution, "seagate goflex usb 3.0 cable, black color, and 4 FEET LENGTH" if u use the above cable, it will work.. there are many other brands having these specs, but i dont know wich brand or any other details. but one condition, if you find a cable like seagte it will work, and that works for me,
THICKNESS of the cable is also important, seagate and toshiba got same thickness. Dont buy belkin,other blue color brand, and cables having high thickness

these solution works for me and my friend
i hope these will work
 

Steve O'Shaunessey

macrumors newbie
Oct 9, 2016
1
0
Hi,
I have a Toshiba 750GB external hard drive that I'm trying to use as a back up drive. When I plug it into my MacBook Pro (bought it maybe 2 weeks ago), it won't mount in the finder or the disk utility. If I plug the hard drive in to any other computer, it mounts no problem. Just not this one. I tried booting into safe mood and then restarting, I checked the permissions in my finder and it should be visible, I looked for it in disk utility but it doesn't show up there. It even shows up in my old MacBook Pro from 2009 which is also running Lion. Just not this one. Please help!!!

Updated: Weirdly enough, it shows up in my system profiler. But nowhere else.
[doublepost=1476034267][/doublepost]My 1 TB hard drive also stopped showing up in finder nd I could not access if via any laptop - I searched all the forums and was about to give up when i saw a link to DiskDrill software - I downloaded it for free and it not only recognized my ghost Toshiba drive - it accessed all my files and I was able to save 60GBs of photos - it is now showing up on the desktop now as an external drive - I wanted to let others know this solution worked for me and hope it does for others.