Does OSX server effect iTunes "ALT" Startup?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by gpspad, Feb 5, 2017.

  1. gpspad macrumors 6502

    Joined:
    Feb 4, 2014
    #1
    I was in the process of moving my iTunes library from one mac to a mini running server and headless. I was moving the iTunes library to a GDRIVE connected via thunderbolt. I followed all the steps posted online and went to start iTunes with the ""ALT/OPTION" key held down to point it to the new library nothing happened.

    I went through all the scenarios to try and fix it. Since I was on screen sharing I tried it on my MacBook, and the holding down the "ALT/OPTION" key worked fine. it wasn't screen sharing or my keyboard that was preventing iTunes from coming up with a switch library dialog.

    Then I changed the user from a limited user to administrator that didn't help. Then I tried using a different account and that made no difference on the mini running server.

    I think it may be a corrupt version of iTunes on my server, but want to try other things before I do something drastic like erase the whole mac mini and start over if its an OSX server bug. its been a long night with everything on the internet saying start iTunes while holding down "ALT/OPTION" and it doing nothing.

    Can someone running server and Sierra try pressing "ALT/OPTION" when starting up iTunes to see if the change library comes up?
     
  2. gpspad thread starter macrumors 6502

    Joined:
    Feb 4, 2014
    #2
    I figured this out. Connected a keyboard to the headless mac mini running server. Then shared the screen like I was, but had someone hold down the alt/option key connected to server machine while I clicked it over the shared screen and it worked.

    For some reason OSX or a combination of OSX and screen sharing is blocking the alt/option key to go through with my apple wireless keyboard.

    The alt/option trick works with screen sharing and the wireless keyboard on my other macs. But not with the headless one running OSX.

    Weird.
     
  3. Brian33 macrumors 6502a

    Joined:
    Apr 30, 2008
    Location:
    USA (Virginia)
    #3
    I'm having the same problem! Holding alt/option while starting iTunes does not bring up the window to choose/create a library! Also true for Photos, even from a newly-created account.

    Combining our reports, I speculate it has to do with using screen sharing with macOS Sierra. Surely others have seen this?

    I had reformatted my Mac Mini and done a fresh install of macOS Sierra 10.12.3 and did not use Migration Assistant. Like yours, my mini is running "headless" and I use screen sharing from my iMac. As an interesting coincidence (?), BEFORE I did the fresh install, I had used OS X Server (under Yosemite) on that Mac Mini. But I can't imagine how that would have an effect after wiping the drives and installing from scratch! I definitely haven't installed Server on Sierra.

    I agree: weird.

    Looks like I'll have to connect a keyboard to the Mini -- thanks for the tip.
    --- Post Merged, Feb 22, 2017 ---
    Still a little weird, but connecting an Apple Magic Keyboard to the headless Mini and using the screen-shared (remote) mouse did the trick. Thank goodness.

    Oddly, the first few times it didn't. The Bluetooth keyboard worked in Terminal, but when I alt-clicked iTunes in the dock the alt-key was ignored for two or three attempts. Then I alt-double-clicked the iTunes.app in Finder and it did work. Then I quit iTunes, and just out of curiosity alt-click the dock iTunes again, and that time it DID register the alt-key. I dunno, maybe some RF interference messing up the bluetooth connection...
     

Share This Page