Does SIM swap work with iOS 7.1.1?

Discussion in 'iOS 7' started by maximini, Apr 22, 2014.

  1. maximini, Apr 22, 2014
    Last edited: Apr 22, 2014

    maximini macrumors member

    Joined:
    Sep 11, 2011
    #1
    It worked with 7.0.6 but not with 7.1. Does it work again in 7.1.1?
     
  2. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
    #2
    Sim swap works with any version. At least for me.
    Why not just try it yourself? If you already are on 7.1 and it dosent work, what do you have to lose when going to 7.1.1
     
  3. maximini thread starter macrumors member

    Joined:
    Sep 11, 2011
    #3
    Changes to APN settings to enable MMS on AT&T MVNOs did not stick using the SIM swap method in 7.1. There was no announcement of this disappearing in 7.1 vs 7.0.6. Who knows what may now be broken by 7.1.1 and why I am not eager to update too quick but if someone did update and MMS works again on an AT&T MVNO (unlocked 4s in my case) then I'd like to know. That at least would restore my faith in Apple's customer service as I don't see why new iOS versions should remove functionality that allows MVNOs and by extension AT&T to make more money... not to mention Apple (happy customers are repeat customers).
     
  4. TheIntruder macrumors 6502a

    TheIntruder

    Joined:
    Jul 2, 2008
    #4
    I rarely use SMS/MMS, so I didn't get a chance to try them directly...but I couldn't get it to work, based on the same loss of cellular data I first saw in 7.1.

    Simply put, getting the mobile web on my MVNO didn't require using any config file (like from the carrier, or the unlockit site), prior to 7.1. The phone would just use the main APN setting entered during the SIM swap ("att.mvno"; it's the last one entered, and has always quickly reverted to "phone" after entered, but it still worked)

    From 7.1 onward, including 7.1.1, if I don't have a config file loaded, the mobile web doesn't work, suggesting that none of the settings entered during the swap are being saved, presumably including the MMS settings.

    There's always the possibility that I'm messing up the swap, but I believe the AT&T carrier 16.0 may be messing things up. IIRC 15.5, the prior version worked with everything, and was the version MVNOs stayed with even as the postpaid and direct users moved to 15.6 and later.

    I'd love to be proven wrong...
     
  5. maximini thread starter macrumors member

    Joined:
    Sep 11, 2011
    #5
    Yes if it doesn't work it could indeed be AT&T's profile effing things up as many non-AT&T or AT&T MVNOS users are now reporting they can activate hotspot settings, which should also allow them to activate MMS... As much as I wish AT&T would update their carrier profile, I have not much hope for this. I hope your transition to 7.1.1 went otherwise smooth! Keep us posted in case MMS end up working!
     

Share This Page