Does SprintView Mobile Broadband work with Snow Leopard?

Discussion in 'Mac Apps and Mac App Store' started by PsyD4Me, Aug 30, 2009.

  1. PsyD4Me macrumors 6502a


    Mar 11, 2009
    under your bed
    I have a sprint mobile broadband on my MBA and wanted to know if anyone updated with/without issues?
  2. likemymac macrumors newbie

    Aug 30, 2009
    Some hiccups with Sprint SmartView

    I've been using Sprint SmartView and had some issues when updating to 10.6. First of all, the SmartView Manager DOESN'T WORK with Snow Leopard. But if you go to Network Connections, you can simply connect there. There's an option now to show the WWAN signal strength in the menu bar, and you can also click there to connect.

    Now, I'm using an external USB broadband card on my MacBook. I'm guessing you are using an internal one?

    Mine is a Sierra Compass 597u just for reference. Sprint Tech Support was useless as usual with Mac issues. Anyone else using a Sierra Wireless 597 or598?
  3. PsyD4Me thread starter macrumors 6502a


    Mar 11, 2009
    under your bed

    i have the 598U usb stick.
    I can connect with the WWAN window, however, for some reason it states: Sprint 2.5G....BUT I have 3G, so is snow leopard messing with my signal?
  4. likemymac macrumors newbie

    Aug 30, 2009
    Not sure about the 2.5 message.... never seen that before. Maybe it's your physical location?

    So here's the latest: I have completely removed all Sprint software from the computer. I use the 597 whenever I need internet. I ignore the install package window when it pops up, and eject the disk image. I'm connecting through the menu bar icon at the top of the screen.

    Sprint still maintains that SmartView is compatible with Mac OS X 10.4.somthing and up. I replied to them that they were WRONG. We'll see.
  5. spkrbox850 macrumors newbie

    Sep 3, 2009
    I had similar issues with 597? (the one with the light up Sprint icon) and 10.6

    Smartview wouldnt connect and kept telling me my drivers were out of date. Everything was fine through network connections for a while but it stopped working so now im on line through XP via parallels. good thing is im not the only one with the problem.
  6. spkrbox850 macrumors newbie

    Sep 3, 2009
    Finally got it to work, this is what I did:

    -uninstalled smartview, restarted
    -installed the latest version of smartview (2.25.0008.0) restarted
    -I started smartview and it told me my drivers were out of date
    -I left smartview running, opened network settings and deleted the 2 parallels adapters (if you dont have a program called parallels installed dont worry about it)
    -I went back to smartview preferences and unchecked 'show status menu bar'
    -from there network settings seemed to take control of the usb connect card, close smartview
    -now THIS is a tricky part that separates 10.5 from 10.6...... Under network settings I have to open the lock to even connect to the internet. seems like things are individually locked in10.6 as opposed to one master lock

    -so unlock it and it should just recognize it, close smartview
    -you should now have something in your menu bar that looks similar to the wifi symbol but its a right triangle. I think the problem is just a conflict between the automatic 10.6 3G drivers and smartview.
  7. likemymac macrumors newbie

    Aug 30, 2009
    Okay... one week later, Sprint finally caught up with the rest of us. I use a Sierra Compass 597 USB modem, but I'm sure you can substitute the steps for yours.

    YOU DO NOT NEED SOFTWARE FROM SPRINT TO RUN YOUR DEVICE ON 10.6. Now that being said, you also cannot adjust preferences/internal settings/GPS features/etc. until Sprint comes up with a 10.6-compliant SmartView Manager.

    Here's what I've done since SL launch day, and what Sprint confirmed to me last night on the phone:

    REMOVE ALL SPRINT SOFTWARE [including the file in the "Library:Application Support:Sprint SmartView" location]

    Boot Up/Wake Up

    Insert USB device.


    Go to System Preferences Pane

    Click on Network Icon

    You should see the Sprint Device along with Airport and Ethernet

    Highlight it

    Under 'Account Name and Password' click connect (if you do this too soon, the device may not have initialized....once it has, you will be able to connect)

    Check the box that says "Show WWAN Status in Menu Bar" [you'll be able to connect/disconnect from there after doing this the first time]

    3G Connection = EVDO REV A connection
    2.5G Connection = CDMA 1xRTT connection

    Kinda crappy, but it does the job until Sprint catches up with the OS
  8. blaine.miller macrumors newbie

    Oct 14, 2009
    Compass 597 in Parallels on Snow Leopard


    I have an Intel MacBook Pro running SL and just upgraded parallels from 3.0 to 4.0.

    The Sierra Wireless dongle was working fine in parallels 3.0 on Leopard. Now, I get a grey box stating that :

    An External connection is already present. Connecting is not allowed.

    Whether the Airport is turned off or on, makes no difference, I can't connect thru the modem with parallels.

    I used the Network connection and it works fine with the Mac version of Sprint's SmartView.

    Anybody have any thoughts or hints?



Share This Page