Does Verizon LTE icon only show up after subscribing?

Discussion in 'iPad' started by jettoblack, Mar 19, 2012.

  1. jettoblack macrumors member

    Joined:
    Nov 1, 2006
    #1
    I've got the Verizon version of the new iPad, LTE is enabled in the settings, and both my house and workplace are deep within the LTE service area according to Verizon's website, so I should have strong LTE coverage.

    When I'm not on wifi, my iPad only shows Verizon 3G (4 bars) in both places. I haven't subscribed to any plan yet though, so I'm wondering if the LTE badge only shows up after setting up a data plan?

    I'd hate to sign up just to find out I'm stuck on 3G even though my area is supposed to be LTE.
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
  3. ckiggins macrumors 6502

    Joined:
    Mar 15, 2012
    Location:
    Richmond, VA
    #3
    +1.

    The LTE symbol did not show up for me until I subscribed.
     
  4. jettoblack thread starter macrumors member

    Joined:
    Nov 1, 2006
    #4
    Great, just what I wanted to hear! Thanks to both of you!
     
  5. bigpatky macrumors regular

    bigpatky

    Joined:
    Sep 7, 2007
    #5
    I've had this exact same question. I was literally just researching it. About to post on MR, too. Thanks for saving me the (minor) trouble!

    I really wish I could run a speed test where I'm at before subscribing. I guess if I'm paying this much for an iPad and am considering so much for a month of data, I shouldn't worry too much. Just would like to know what speeds I get in my area. Employees at the Apple Store had no clue when I asked around.
     
  6. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #6
    Same for me. LTE didn't show up until subscribing to a plan.
     
  7. ewo1992 macrumors regular

    ewo1992

    Joined:
    Mar 11, 2012
    Location:
    Southern, CA
    #7
    Turn off the wifi in the setting then it will show if you have 3G or 4g
     
  8. kevin2577 macrumors newbie

    Joined:
    Feb 17, 2011
    #8
    Is this also true for AT&T LTE?

    Is this the same for AT&T iPads? I'm in a similar situation as the OP except for AT&T, I have the 4G iPad for AT&T and am in an LTE service area but my status bar shows their fake "4G". Will it show LTE only after subscribing?
     
  9. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #9
    Yes, as confirmed in other threads you only get to see the LTE indicator after subscribing for data.
     

Share This Page