Does VMware Fusion slow down Snow Leopard?

Discussion in 'Mac Basics and Help' started by wants2tryMac, Nov 17, 2009.

  1. wants2tryMac macrumors newbie

    Joined:
    Jul 12, 2009
    #1
    Hi guys,
    I recently installed VMware fusion on my MBP, but I later noticed it to be slower.
    I dedicated about 2GB of RAM to the Virtual Machine. The Windows 7 OS runs fine, but it's the Snow Leopard that became sluggish.
    Any help? Do I need to change any settings on the Virtual Machine to make my SL run faster?
    I really miss my fast SL!:(
    Any help would do.:)
    Thanks
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Of course it does. Virtualizing an OS is a processor-intensive process, since you are running twice as many operating systems on your computer, one of which has a bunch of virtualization overhead. Decrease the amount of memory allocated to your virtual machine and/or pause it when not in use.
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    In addition to reducing the amount of memory allocated to the VM, you can tell Fusion to give priority to OS X, rather than the VM. It will help, but you will still see a performance hit when running both OSes.
     
  4. wants2tryMac thread starter macrumors newbie

    Joined:
    Jul 12, 2009
  5. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
  6. EndlessMac macrumors 6502

    Joined:
    Aug 20, 2009
    #6
    You should only give Windows in Fusion as much resource as it needs to run smoothly but no more. As others have mentioned you are running two OS at the same time so in a way it's like dividing your computer into two or cutting its performance in half but it's worst on the Mac side because your Mac has to run Fusion in addition to everything else. Windows just needs to run itself so I personally think you should give more resources to your Mac.

    That's how I have my VMware Fusion setup and it runs great. You should try lowering your RAM to 1GB and make sure Windows is only using 1 Core Processor unless you have 4 or more core processors. If that doesn't work for you then try adjusting your settings again and see which one works for you.
     

Share This Page