Does ZiPhone 2.4 downgrade bootloader or not?

Discussion in 'Jailbreaks and iOS Hacks' started by jamescwarren, Feb 25, 2008.

  1. jamescwarren macrumors 6502

    jamescwarren

    Joined:
    Dec 10, 2005
    Location:
    Isle of Man
    #1
    I am hopefully unlocking an iPhone on Wednesday. I know I have the choice between iJailBreak 0.5.3 and ZiPhone 2.4. Based on scouring these forums, I think I am going to go with ZiPhone 2.4. (If people agree or disagree, do let me know). ZiPhone 2.4 looks perfect, but I have seen varied reports; some say it downgrades the bootloader, some say it doesn't. I need one answer, full stop. Does it downgrade it or not? If it does, is it a bad thing and can it be reversed? Does iJailBreak do this?

    Thanks!
     
  2. mikejoann macrumors newbie

    Joined:
    Feb 25, 2008
    #2
    Member,
    The answer to your question is I have used the ziphone method on my new 16GB iPhone and infact ziphone did indeed downgrade my bootloader from 4.6 to 3.9 my phone is now unlocked with 100 percent full functionality. Everything works including the locate me feature in google maps app. Also it seems that my phone is dropping less calls since the 3.9 bootloader downgrade. So your answer from me us yes but as stated all works 100 percent. Hope this helps you. Mike
     
  3. shane1598 macrumors member

    Joined:
    Sep 12, 2007
    Location:
    St. Louis
    #3
    I used 2.4 gui to Jailbreak ONLY and it did NOT dg my bloader. but i think unlocking will...
     
  4. Diatribe macrumors 601

    Diatribe

    Joined:
    Jan 8, 2004
    Location:
    Back in the motherland
    #4
    I have heard more people say that it does than people that it doesn't.

    The problem with downgrading the bootloader is that there is no way to change it back so if someone ever comes out with a custom bootloader that is immune to security checks than everyone with a 3.9 bootloader is out of luck.

    Basically it is being on the safe side for a "possible" custom bootloader. There is nothing inherently bad about a 3.9 bootloader besides the fact that you cannot change it to anything else.

    And next time don't bump threads within a couple of hours. It is bad form. ;)
     
  5. Ol!ver macrumors 6502a

    Joined:
    Mar 2, 2005
    #5
    Just to confuse matters, my brand new 1.1.2 iPhone DID NOT get downgraded. I unlocked/jailbroke.
     
  6. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #6
    Sorry if this is a dumb question, but if the bootloader can be downgraded, why couldn't you use the same method to upgrade it?

    It wasn't downgradeable (via software) until recently.
     
  7. Diatribe macrumors 601

    Diatribe

    Joined:
    Jan 8, 2004
    Location:
    Back in the motherland
    #7
    There is an exploit in the 4.6 bootloader as far as I understand it that makes this possible. But currently there is no exploit for the 3.9 bootloader, which is why you cannot change it back.
     
  8. brianbkny macrumors member

    Joined:
    Dec 27, 2004
    #8
    if you restore your phone through itunes, will that bump the bootloader back to 4.6?
     
  9. Diatribe macrumors 601

    Diatribe

    Joined:
    Jan 8, 2004
    Location:
    Back in the motherland
    #9
    No it won't.
     
  10. Subculture macrumors newbie

    Joined:
    Aug 15, 2007
    #10
    I used ZiPhone 2.4 via command line (ziphone -a -j -u) and it did not downgrade my bootloader. I'm still at 4.6. Everything works except the "locate me" feature in Google Maps, which is a side effect of still having BL4.6.

    I activated an OTB 16GB for use on the Rogers network here in Canada and it works GREAT!
     
  11. jamescwarren thread starter macrumors 6502

    jamescwarren

    Joined:
    Dec 10, 2005
    Location:
    Isle of Man
    #11
    So if I was to use ZiPhone 2.4 GUI, it will downgrade the bootloader? And if I use terminal, it won't? If this is the case, can somebody post how to do this in Terminal or post me a link on how to do this, as this will probably be my chosen choice.
     
  12. jamescwarren thread starter macrumors 6502

    jamescwarren

    Joined:
    Dec 10, 2005
    Location:
    Isle of Man
  13. brianbkny macrumors member

    Joined:
    Dec 27, 2004
    #13
    also, does it only downgrade when you unlock? what if you are just jailbreaking the phone (with att service)?
     
  14. jamescwarren thread starter macrumors 6502

    jamescwarren

    Joined:
    Dec 10, 2005
    Location:
    Isle of Man
    #14
    Please can someone reply to my question a few posts above?^^^^

    Thank you!
     
  15. spenner macrumors newbie

    Joined:
    Feb 20, 2008
    #15
    I'm not sure if this helps anybody but here goes.

    I originally used the downgrade and jailbreak method to unlock and activate my 16GB OTB iPhone. This worked fine, but unfortnately I made a balls of something and so restored to OTB using iTunes and then used ZiPhone 2.4.

    After Ziphone 2.4 everything works fine, apart from Maps location. I have now installed the Baseband Info applet via Installer and this is the results I get back from the Baseband test it does:

    Modem Firmware: 04.02.13_G
    Bootloader Version: 4.6_MS32

    From these results I deduce that the modem firmware has been downgraded from 04.03.13 and the the Bootloader Version is the same as the shipped condition.

    All the other results from the Baseband test are the same i.e. IMEI, Serial Number etc.

    Hopes this help.
     
  16. Diatribe macrumors 601

    Diatribe

    Joined:
    Jan 8, 2004
    Location:
    Back in the motherland
    #16
    Did you use the GUI version or the command line version?
     
  17. spenner macrumors newbie

    Joined:
    Feb 20, 2008
    #17
    I used the GUI version, just ticked the 3 boxes on the 'Standard Options" screen.

    I'm running OSX 10.4.11 (Tiger not Leopard) by the way, I know some people have said they can't use ZiPhone on Tiger but it worked perfectly for me.

    I've tried all iPhone functions using both a Vodafone contract sim and Orange pay as you go sim.
     
  18. Diatribe macrumors 601

    Diatribe

    Joined:
    Jan 8, 2004
    Location:
    Back in the motherland
    #18
    Sounds great. So I guess it doesn't downgrade the bootloader. Is everything working for you (youtube, locateme, etc.)?
     
  19. spenner macrumors newbie

    Joined:
    Feb 20, 2008
    #19
    All working great, just the Maps Location tool doesn't work.

    Everything works on both wireless and GPRS connection via my Vodafone contract. Only thing I can't do via GPRS is send emails, but I couldn't do this before on my K850i, couldn't work out what the problem was before so not right bothered at the moment.

    Just glad I've got a working iPhone without O2 contract!
     
  20. jamescwarren thread starter macrumors 6502

    jamescwarren

    Joined:
    Dec 10, 2005
    Location:
    Isle of Man
    #20
    Just to let you all know, I just unlocked, activated and jailbreaked my OOTB 16 GB US iPhone for use here in the UK using the command prompt in Terminal and... IT'S FANTASTIC! WELL DONE TO THE CREATOR OF ZIPHONE IT'S AMAZING! I knew it didn't take long but to see it in front of your own eyes is just... WOW! I don't know whether it downgraded to bootloader as I don't know how to check, but everything works seamlessly! Thank you!!!
     
  21. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #21
    I have a 16g 1.1.3 iPhone that I upgraded to 1.1.4 yesterday and jailbroke today using the ziphone 2.4 and my baseband is still 4.6. Everything works. Youtube, mail, ringers, internet, my sanity...:rolleyes:

    I cant be happier (well there is that SDK thing):apple:
     
  22. georgeoommen macrumors regular

    Joined:
    Apr 12, 2007
    #22
    how do you check what eversion the bootloader is?
     
  23. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #23
  24. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #24
    Except now I can no longer download apps. I am assuming the source is offline again. Ick.
     

Share This Page