Don't dim my screen?

Kalixa

macrumors member
Original poster
Jun 25, 2007
73
0
Hello. The screen on my macbook pro dim's itself after what seems to be just a minute or two. I have set my screen to go to sleep after 20 minutes in system preferences, so I suspect that this is something else. I don't want to screen to dim itself, so how can I disable this, or atleast change the time limit?
 

siurpeeman

macrumors 603
Dec 2, 2006
6,311
18
the OC
sorry, i thought you were talking about something else. to my knowledge, it does this when it's on battery power. after x minutes, the screen dims itself and then goes to sleep after whatever time you set it to.

*edit*
yes, xUKHCx is right. here is what you want unchecked.
 

Attachments

xUKHCx

Administrator emeritus
Jan 15, 2006
12,587
6
The Kop
Maybe

System Preference - Energy Saver - Options -Automatically reduce the brightness of the display before going to sleep.
 

Kalixa

macrumors member
Original poster
Jun 25, 2007
73
0
Maybe

System Preference - Energy Saver - Options -Automatically reduce the brightness of the display before going to sleep.
I have unchecked this box, but it still dim's it. I don't get it.
 

GuillaumeB

macrumors 6502
Jul 4, 2007
419
9
Just behind you
Nope actually it might be the light power recognition.

The screen will automatically dim itself when the external light is low so as to avoid strong reflexions on your eyes . This is supposed to make it easier for you to read (and preserve your vision!). Also you will notice that if the environment is dark or hardly enlightened then the keyboard will automatically light up for you to find the right keys.

I switched about a month ago on a MacBook pro. It used to bother me the first week but then I realized it's kind of really smart.

I dunno where to turn it off
 

ultimateceej

macrumors regular
Jul 24, 2007
176
0
Texas
Nope actually it might be the light power recognition.

The screen will automatically dim itself when the external light is low so as to avoid strong reflexions on your eyes . This is supposed to make it easier for you to read (and preserve your vision!). Also you will notice that if the environment is dark or hardly enlightened then the keyboard will automatically light up for you to find the right keys.

I switched about a month ago on a MacBook pro. It used to bother me the first week but then I realized it's kind of really smart.

I dunno where to turn it off
You can disable this in System Preferences > Displays

There's a checkbox at the bottom.
 

Kalixa

macrumors member
Original poster
Jun 25, 2007
73
0
You can disable this in System Preferences > Displays

There's a checkbox at the bottom.
I have unchecked this box. And the screen still dims itself!
I have no idea why it is so, and it really does suck.
 

xUKHCx

Administrator emeritus
Jan 15, 2006
12,587
6
The Kop
Are you editting the settings for the correct power option, i.e. for battery rather than ac power adapter.