Doom 3 won't even start on my IMac

Discussion in 'Mac and PC Games' started by nolanisgood, Jun 5, 2008.

  1. nolanisgood macrumors newbie

    Joined:
    Jun 5, 2008
    #1
    I just Bought a top of the line model not but two days ago and then chose to get a triumphant game to go along with it. So I put Doom 3 in there's sound but NO VISUAL WHATSOEVER. Just an industrial gothic soundtrack and what sounds like logos coming and going but I wouldn't know because I've never seen it. I've tried installing it onto the HD and not the desktop, tried repairing the disk, I've played with brightness and visual requirements, I re-installed it many a time and of course randomly smacked buttons like I was an angry baboon but nothing to any avail. Also I've watched several movies on it with not a hint of a trouble but now this. If any of you find it in your hearts to help this pitiful creature I would forever be in your debt. Here are my computer details:

    Model Name: iMac
    Model Identifier: iMac8,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.8 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 2 GB
    Bus Speed: 1.07 GHz
    SMC Version: 1.30f1
     
  2. Dan.Dare macrumors member

    Joined:
    May 12, 2008
    Location:
    East Angular, UK
    #2
    Your description of the music sounds right so the game is there. But can I ask how you entered the authorisation key if you can't see any picture?

    Have you downloaded and installed the 1.3 patch from Aspyr?
     
  3. nolanisgood thread starter macrumors newbie

    Joined:
    Jun 5, 2008
    #3
    The key is before the actual gameplay graphics. but anyways I did learn about the patch elsewhere and the problem is solved. thanks anyways
     

Share This Page