Doom 3 won't play on new SR 15" MBP!

Discussion in 'MacBook Pro' started by Watermonkey, Jun 24, 2007.

  1. Watermonkey macrumors member

    Watermonkey

    Joined:
    Oct 27, 2006
    Location:
    NE Washington State
    #1
    It locked up the computer twice and I was able to cmd-Q out the third time after the weird graphic it displayed that didn't even remotely resemble the game. Anyone else have trouble with high-end games on their new laptop?
     
  2. Sopranino macrumors 6502

    Joined:
    Sep 27, 2006
    Location:
    Alberta, Canada
    #2
    Several questions to start things off.

    1) Was this a PC or Mac version of Doom?
    2) If PC were you trying to run in a VM or through Bootcamp?
    3) At what stage in the boot cycle for the game did you encounter the weird graphic?
    4) Did it display the weird graphic everytime it locked up?
    5) Were you able to adjust any game play options prior to getting the weird graphic? (As in did you adjust any display variables?)

    Post back with as much info as possible and I'll try to help you out.

    Sopranino
     
  3. uicandrew macrumors 6502a

    Joined:
    Jan 19, 2006
    #3
    i personally have played need for speed carbon and Call of Duty 2 with no problems.
     
  4. Sbrocket macrumors 65816

    Sbrocket

    Joined:
    Jun 3, 2007
    Location:
    /dev/null
    #4
    Turn anti-aliasing off and try it again. There's a bug in both the Windows and Mac versions of the Nvidia 8600M GT drivers that come on the MBPs and are installed by Boot Camp that, at least on my machine, either freezes the machine with a error dump to the Console (on OSX obviously, check your system.log file in Console for the error below) or causes a IRQL_LESS_THAN_OR_EQUAL BSOD in Windows.

    Of course, YMMV but this is what I have discovered so far from my testing. About to submit a bug report over at ADC and see what Apple has to say.

    system.log error:
    Jun 24 19:36:27 ******** kernel[0]: NVChannel(GL): Graphics channel exception! status = 0xffff info32 = 0xd = GR: SW Notify Error
    Jun 24 19:36:27 ******** kernel[0]: 0000000c
    Jun 24 19:36:27 ******** kernel[0]: 00200000 00005097 0000047c 00000000
    Jun 24 19:36:27 ******** kernel[0]: 00000486 00000f10 00000000 00000003
    Jun 24 19:36:27 ******** kernel[0]: 00000000 00000000 00000002
     
  5. Sbrocket macrumors 65816

    Sbrocket

    Joined:
    Jun 3, 2007
    Location:
    /dev/null
    #5
    I'm just wondering, does anyone with a new SR MBP notice this except me? I haven't seen any reports like mine except for one here, which is really weird if its a driver problem.

    Would someone else be willing to test this on their hardware to make sure it isn't a red herring? If I know it isn't an isolated thing I can gather the information for the ADC bug report.
     
  6. Watermonkey thread starter macrumors member

    Watermonkey

    Joined:
    Oct 27, 2006
    Location:
    NE Washington State
    #6
    This is the Mac edition, version 3.1 I believe. It crashes during the initial startup within about 10-15 seconds of launching and the soundtrack goes into a loop and that's when you know you're out of luck and hold down the power key. Except the last time I attempted. It made it through the startup and began showing a mostly yellow partial screen with what appeared to be artifacts of images from the game, but really vague. cmd-Q allowed me to exit that time and I've not tried since.

    ...and, no, I was never able to read, see, or use the menu screen or make any game parameter changes. I only saw any image on that last attempt. The others were with a blank screen.
     
  7. Watermonkey thread starter macrumors member

    Watermonkey

    Joined:
    Oct 27, 2006
    Location:
    NE Washington State
    #7
    same errors

    My printout is nearly identical to yours:

    Jun 24 22:52:33 *****kernel[0]: NVChannel(GL): Graphics channel exception! status = 0xffff info32 = 0xd = GR: SW Notify Error
    Jun 24 22:52:33 ***** kernel[0]: 0000000c
    Jun 24 22:52:33 ***** kernel[0]: 00200000 00005097 0000047c 00000000
    Jun 24 22:52:33 ***** kernel[0]: 00000486 000015f0 55000000 00000003
    Jun 24 22:52:33 ***** kernel[0]: 00000000 00000000 00000000
    Jun 24 22:52:33 ***** kernel[0]: 0000000c
    Jun 24 22:52:33 ***** kernel[0]: 00200000 00005097 0000047c 00000000
    Jun 24 22:52:33 ***** kernel[0]: 00000486 000015f0 55000000 00000003
    Jun 24 22:52:33 ***** kernel[0]: 00000000 00000000 00000000
     
  8. robrose20 macrumors 6502

    robrose20

    Joined:
    Jun 5, 2007
    #8
    I think it will take some time before they work out the issues with the new NVIDIA graphics adapter. I have the same problem with Civilization 4, when I play it in high graphics mode it crashes. When it is in low graphics mode it works just fine. Hopefully in the next few months they will release updated drivers and everything will be fine.
     
  9. Megatron macrumors regular

    Joined:
    Nov 19, 2005
    #9
    I have the 15" 2.2 SR MBP, and Quake 4 (which I believe uses the Doom 3 engine) loaded up just fine without me adjusting anything. Played through the demo with no problems / glitches. I was running it in OS X - haven't tried it in windows yet.
     
  10. ecyras macrumors newbie

    Joined:
    Feb 7, 2008
    #10

Share This Page