Double Birthdays in Calendar

Discussion in 'OS X Mountain Lion (10.8)' started by macpeach55, Jul 31, 2012.

  1. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #1
    Hi,

    After the upgrade to Mountain Lion, I have all Birthdays showing twice in Calendar.

    In Contacts all my cards show that there are linked cards on my mac and in iCloud, so I wonder if this is the cause - but if the cards are linked it seems strange that they would produce two entries.

    I did an upgrade, not a clean install by the way.

    Any thoughts anyone?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Click on the Calendars button in my screen cap and what do you see there? Is Birthdays there more than once?

    [​IMG]
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
  4. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #4
    No, just the one.
     
  5. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #5
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    I think this is the issue. You don't want those both there, you normally would just want the iCloud contacts there (assuming they are the same).

    Before you start monkeying around, start contacts and do a command-a to select all contacts, then go to the File menu and Export and export to VCard as a backup. Don't want you to lose any data.
     
  7. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #7
    Ok, thanks - export is done and safely on my desktop
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    Okay, now delete all contacts from both iCloud and On My Mac so the entire address book is empty. Then import that Vcard file and when it asks where to import point it to iCloud. That should get all your contacts in just iCloud.
     
  9. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #9
    I just deleted all the contacts from On my Mac, but stopped there to ask - all the groups are now empty. The Groups in iCloud are still there online, but they don't show up in the address book - the only item above On My Mac is "All Contacts"
    I am concerned about losing all the Groups if I delete the iCloud contacts as well, and wonder how to get the iCloud Groups to show in my Address Book
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    The VCard format does not remember groups, so you will lose that. The problem is the second export format on the export menu gives you a .ABBU format that does remember groups, but can't be imported to iCloud. Catch 22. I went through this myself when iCloud first came out. It is mentioned in the below Apple Support article.

    I suspect the reason you are still seeing groups at iCloud.com is the Address Book sync just has not caught up yet.

    http://support.apple.com/kb/HT4910
     
  11. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #11
    Ok, thank you all understood. Then I will try and do a roll back for now as my groups are more important to me than the doubled-up Birthdays :)

    Thank you for all the help - very much appreciated!!
     
  12. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #12
    A Happy ending! rolled back the Address Book On My Mac so all my Groups are working again, but the duplicate Birthdays are gone! Fantastic! :)
     
  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #13
    Excellent! :D
     
  14. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #14
    Ah, spoke too soon; the double entries are back this morning - I thought it was too good to be true!:(
     
  15. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #15
    Can you move the On my Mac entries over into the iCloud section, then remove duplicates? If you look under the Card menu there is a remove duplicates command. It does look like having On my Mac and iCloud both is causing this.
     
  16. tkermit macrumors 68030

    tkermit

    Joined:
    Feb 20, 2004
    #16
    Have you tried to remove and add again this checkmark. Solved it for me...

    [​IMG]
     
  17. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #17
    The two sets of Contacts are identical, and if I look at any card, they all say

    Linked Card On My Mac
    iCloud

    But if I remove the On My Mac Cards, the Groups in my Address Book remain, but are all empty. The Groups in iCloud (looked at online or on my iPad for example) remain populated.

    So definitely the problem is caused by the two sets of cards, but the problem is keeping the Groups populated in the Address Book - it would be a long process to manually repopulate them :eek:

    ----------

    Just tried it - even un-ticked, closed Calendar, and re-ticked, but still double entries and double reminders :(
     
  18. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #18
    Look in iTunes for each iOS device and under the info tab make sure all those Sync Calendar and Sync Contacts settings are unchecked. If they are checked that will manually sync a set in iTunes and another set in iCloud.

    Also, make sure you have this setting in Contacts prefs set so new entries go to iCloud.

    [​IMG]

    Another thought. How many groups do you have?

    You can export VCards by group. Open the third pane in the left side of Contacts so you can see all the groups. Mouse grab a group and drag it to the desktop. That will give you a VCF file with just the contacts in that group.

    Do this for each group and you will have let's say five VCF files. (Also to the command-a to select all first to get all the cards in one file as a second backup, plus your normal backup so we can undo this)

    Now delete all entries in the address book including iCloud and On my Mac. Give it a minute to sync and check icloud.com to make sure everything is gone.

    If they are gone, recreate all your blank groups name under the iCloud section in the left pane.

    Now drag the first group VCF file into Contacts. They import and be listed in the Last Import smart group on the left. Click the Last Import group and select then drag all those cards into the group you want.

    Now drag the second group VCF file in. It will not be listed in the Last Import group. Do the same thing, and drag it into it's group name. Do this for each group VCF.

    If you only have a few groups this will get the job done manually.
     
  19. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #19
    I did these settings when I moved to iCloud and all are already as you suggest, except Calendars on my iPod Touch as that does not sync with iCloud.

    And unfortunately I have a lot of Groups, probably 50, all necessary for Business. So that would be a big operation. I imagine there has to be a way to "see the iCloud Groups in Address book, just need to figure out how.
     
  20. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #20
    If you have manual Contacts sync turned on in iTunes for ANY device like you do for your iPod Touch, that will create a On my Mac set in Contacts. You might try just temporarily turning that off if iTunes and see what happens.

    I search some, and don't see any easy way to automate this. :confused:
     
  21. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #21
    Contacts are totally off in ITunes for both devices. They both sync Contacts only via iCloud, just with the Touch there is no iCloud sync option for Calendars. I have anyway temporarily turned that off but no change on Birthdays. :(
     
  22. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #22
    What happens when you do the Look for Duplicates command in the menu? Will that allow a merge of the two maybe?
     
  23. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #23
    Nope - because they are "Linked" it sees them as a single card for each entry
     
  24. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #24
    Bah! :mad: I don't see a way around this other than a manual export and import like I described. Maybe somebody else will chime in with a better idea.
     
  25. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #25
    Yeah, fingers crossed on that!
    I popped a question onto the Apple USA Forum, but that is always so swamped with postings I doubt I will get a reply
     

Share This Page