Double clicking doesn't do what it used to (highlight text)?

Kevster89

macrumors regular
Original poster
Oct 14, 2008
140
0
For some reason, double clicking the trackpad button or with one finger on the trackpad itself (tap-tap, essentially), does not do what it used to.

For instance, if I go to the URL box/bar on the top of Safari double clicking no longer highlights the entire URL string so I can delete it. I manually have to drag from one side to the other, or click the little website icon in the left of the box.

In every single application, double clicking (or tapping) no longer highlights text. It's a pain to always have to drag all the time. Anyone know why this could be?

Thanks.. any help would be greatly appreciated. My MacBook Pro is making me angry!

:apple: 15 inch MacBook Pro - Early 2008 :apple: 10.5.5 :apple: iPhone 3G 16 GB black :apple:
 

Kevster89

macrumors regular
Original poster
Oct 14, 2008
140
0
Click on the bar below the touchpad. Double clicking, when the curser is on a word, will highlight the word.
No this is not what I'm trying to do. I know how to do what yore describing. If I'm in word and double click with the cursor over a paragraph, it won't highlight the entire thing and nothing will happen. If I drag the cursor to the URL bar and double click, the entire thing won't be highlighted as it should and always usedto do until recently.
 

apfhex

macrumors 68030
Aug 8, 2006
2,670
4
Northern California
If I drag the cursor to the URL bar and double click, the entire thing won't be highlighted as it should and always used to do until recently.
I can't say for Word (as MS products always seem to want to do their own thing) but in most Mac apps, double clicking will highlight the word. Triple clicking highlights the line. Same for the URL bar. Clicking on the favicon (the icon to the left of the URL) will highlight the whole URL in Safari. This is how it's always been.
 

Kevster89

macrumors regular
Original poster
Oct 14, 2008
140
0
I can't say for Word (as MS products always seem to want to do their own thing) but in most Mac apps, double clicking will highlight the word. Triple clicking highlights the line. Same for the URL bar. Clicking on the favicon (the icon to the left of the URL) will highlight the whole URL in Safari. This is how it's always been.
Thanks for the clarification. From what I have been able to notice on my MBP, double clicking sometimes highlights the word but triple clicking will NEVER highlight the entire line, such as the URL. However, clicking the favicon does indeed highlight the URL. Any idea why this might be?
 

Kevster89

macrumors regular
Original poster
Oct 14, 2008
140
0
Figured it out

Thanks for all your help/suggestions.

I FINALLY figured it out. I went into System Preferences - Keyboard and Mouse - Trackpad, and noticed the "slide icon" for Double Click Speed was moved all the way to the right, meaning that the computer would only recognize a double click (or double tap on the trackpad) if done extremely rapidly. Furthermore, I moved the "slide icon" a few notches to the left and now it works perfect again... just as it should for the click, double-click (word highlighting), and triple click (line, paragraph, etc., highlighting).
 

WordHighlight

macrumors newbie
Dec 7, 2009
1
0
Here's something for you to tackle:

I'm having a similar problem–up until yesterday, double-clicking on a word in Word for Mac 08 would highlight the word. A triple-click would highlight the paragraph.
This function still works in other applications, such as Firefox, etc. But it no longer works in Word. I click over and over and the insertion point just sits there and laughs at me.

HELP PLEASE!
 

timlevin

macrumors newbie
Mar 24, 2010
5
0
Here's something for you to tackle:

I'm having a similar problem–up until yesterday, double-clicking on a word in Word for Mac 08 would highlight the word. A triple-click would highlight the paragraph.
This function still works in other applications, such as Firefox, etc. But it no longer works in Word. I click over and over and the insertion point just sits there and laughs at me.

HELP PLEASE!
I have the same problem: in Mac Word, double clicking no longer highlights the word that the cursor is on. Any help would be appreciated. There does not seem to be any items under Mac or Word preferences that would fix this.

-Tim
 

yeastbeast

macrumors newbie
Mar 25, 2011
1
0
I'm having the same problem, and the proposed fix in post #7 didn't help.

For me the problem is specific to Microsoft Word 2011 (version 14.0.1). Double- and triple-clicking to highlight words and lines respectively works just fine in Firefox 4.0 RC2.

I'm on a MacBook Pro i7 in MacOS 10.6.6
 

tamela714

macrumors newbie
Apr 1, 2011
2
0
double click not working

I am the same problem. my double click is not working in Word and no adjustments in Preferences are restoring it. Also, my cursor keeps jumping randomly to previous spots in typed text! HELP!!
 

tamela714

macrumors newbie
Apr 1, 2011
2
0
Double click not working - Fix

I just downloaded the available software updates and it fixed all the problems.
 

nanette75

macrumors newbie
Apr 29, 2011
1
0
Double click not working - software

tamela714,
as I have the same problem (my double click is not working in Word),
could you please tell me which software you've download?

Thanks a lot
 

sebseb81

macrumors member
Dec 12, 2010
84
0
I have the latest updates for Word and double-clicking to highlight text does not work for me (it does work in all other programs).

Any ideas?
 

tdingott

macrumors newbie
Sep 7, 2012
1
0
Thank you

I was getting beyond frustrated at losing the ability to double click to select words in MS Word. Visiting the Cnet web site posted below explaining the need to go to System Preferences / Universal Access worked like a charm. I had never even realized those options existed. Thanks to anglingz.
 

jfdouble

macrumors newbie
Oct 25, 2011
2
0
In Mountain Lion (10.8), the Double-Click speed option has disappeared completely from the Mouse & Trackpad settings. You need to always go to Universal Access now.
 

lookman

macrumors newbie
Apr 17, 2013
1
0
This worked for me!!!!!!!!!!!

what you need to do is go to universal access ON SYSTEM PREFERNCES, CLICK ON TRACKPAD OPTIONS AND slow down the double click speed of your trackpad cause you set it to maximum so your double click is now basically like a single click lol, thats what i did and now when i click once it selects the word and when i click twice it selects the whole sentence. HOPE IT WORKS
 

Vannfe

macrumors newbie
Nov 19, 2015
1
0
For some reason, double clicking the trackpad button or with one finger on the trackpad itself (tap-tap, essentially), does not do what it used to.

For instance, if I go to the URL box/bar on the top of Safari double clicking no longer highlights the entire URL string so I can delete it. I manually have to drag from one side to the other, or click the little website icon in the left of the box.

In every single application, double clicking (or tapping) no longer highlights text. It's a pain to always have to drag all the time. Anyone know why this could be?

Thanks.. any help would be greatly appreciated. My MacBook Pro is making me angry!

:apple: 15 inch MacBook Pro - Early 2008 :apple: 10.5.5 :apple: iPhone 3G 16 GB black :apple:
I have a MacBook Pro working on OS X Yosemite 10.10.5 and having been having the same issue. I tried all the recommendations from previous posters, as this is an older post, and none worked. I have a couple reports due to today and this has been driving me nuts. So I have spent the last hour or so trying to fix it and just did. This is what worked for me: System Preferences > Keyboard > adjust Delay Until Repeat to the right (short) by one notch. Hope this is helpful to someone else. :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.