Double contacts problem

Discussion in 'iOS 5 and earlier' started by drkash, Oct 31, 2011.

  1. drkash macrumors regular

    Joined:
    Jul 19, 2010
    Location:
    UK
    #1
    I'm using my iphone 4s and have my contacts doubled..."On my iPhone" and "iCloud"

    I know I can select each group and see only one set of the contacts, but the contacts are doubled in some apps and becomes annoying.

    I could try turning iCloud off and then back on to see if that helps but I have new contacts saved to iCloud so dont want to lose these.

    Any suggestions as to how I can delete all contacts "On my iPhone"??
    Do others also have double contacts like this? Is this how it was meant to be?

    Thanks
     
  2. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    There were 6 people gathered around a table at the apple store with this problem as well as their calendar duplicating. I should have stayed a little longer to see if they figured it out
     
  3. gdjsnyder macrumors 6502a

    gdjsnyder

    Joined:
    Apr 19, 2010
    Location:
    Swoyersville, PA
    #3
    Connect your iPhone to your computer (WiFi sync or cable), go into the summary tab and uncheckmark the "Sync Contacts" option. This will leave only your iCloud contacts on your phone.
     
  4. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #4
    That's certainly not how it was meant to be.


    The only solution I can think of (hopefully someone has a better one) would be the following:
    1. Turn off Contacts under iCloud settings (you should be prompted to either keep them on your iPhone or delete them)
    2. Select "Delete"
    3. Turn on Contacts under iCloud settings (you should be prompted to either merge the contacts on your iPhone with iCloud or not)
    4. Select "Merge"
    That should remove the contacts that are "On My iPhone" however it will also remove those new iCloud-only contacts that you mentioned. Sorry I don't have a better solution.
     
  5. drkash thread starter macrumors regular

    Joined:
    Jul 19, 2010
    Location:
    UK
    #5
    It already is unchecked

    ----------

    Great that worked!
    Thanks:)
     

Share This Page