doublequote and atsign swapped using my non-Mac keyboard

confuzatron

macrumors newbie
Original poster
Jan 16, 2005
19
0
Edinburgh, Scotland
Hi,
I'm using my new Mac mini with my existing PC keyboard (a UK MS 'Natural' Keyboard Pro). When I type @ I get a ", and vice versa.

In fact, I just noticed a large number of other keys dont do what they have printed on them (pound sterling sign, hash, tilde, etc). In Windows I'd be looking for somewhere to set the type of the keyboard, but in OSX - no idea!

Does anyone know how to fix this problem?
 

stoid

macrumors 601
You may need to go into International in System Preferences and change the keyboard input type under Input Menu. I don't know what (if any) you should change it to though. There is a British one, so maybe that will fix it.
 

confuzatron

macrumors newbie
Original poster
Jan 16, 2005
19
0
Edinburgh, Scotland
stoid said:
You may need to go into International in System Preferences and change the keyboard input type under Input Menu. I don't know what (if any) you should change it to though. There is a British one, so maybe that will fix it.
Aha. Changing that to 'british' does correctly change SHIFT+3 from the 'hash' sign (With keyboard set to 'british' there does not seem to be a key that prints out that character) to the £ sign.
However, " and @ are still transposed.
(and tilde comes out as vertical bar, vertical bar comes out as ±, backslash comes out as §, logical not (SHIFT+key to left of 1) comes out as ~ etc etc :eek:
argh!
The weird thing is I have the driver software installed for this keyboard that enables all its extra buttons (back forward volume± etc) - ie it's supported on OSX. :confused:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.